Can't play game anymore

Issue:
Yesterday, I was able to play Layton vs. Wright just fine. When I tried today, the emulator freezes with the touchscreen being completely black and the other dark gray. When i tried playing on another pc, it mostly worked, but i got an error in-game when trying to save in game after loading a savestate. The saves and the savestates are not corrupted so that probably isnt the issue. I redumped the game just in case and it still doesn’t work so the rom is fine as well. Reinstalling the emulator, or using the nightly build, doesnt help either. I really don’t know how to fix it.

It probably started after having to restart the pc when citra was still opened. The pc had trouble with the login screen after it went to sleep mode, so i had to restart the pc. Luckily, i had a savestate from before the reboot. After the reboot, citra started having these problems on this pc.

System Information

  • Operating System: Windows 10
  • CPU: intel i3-3120M
  • GPU: intel hd graphics 4000
  • Citra Version (found in title bar): 1970 canary
  • Game: Professor Layton vs. Phoenix Wright: Ace Attorney
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
<
citra_log.txt (16.1 KB)

System Information for Support

Client Version                                Canary 1970 HEAD-7ee5bf9
Operating System                              Windows 10 (10.0)
CPU                                                  Intel(R) Core(TM) i3-3120M CPU @ 2.50GHz | AVX
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 4000
GPU Driver Version                            10.18.10.4358
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [ ]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 2
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. Downloads for Graphics

Okay, i did not expect the citra support bot to actually be useful, but updating the drivers seems to have fixed my problem, even though i do not understand why.

Well 10.18.10.4358 is from 2016, while like 5161 is from 2021. You have caught up on 5 years of driver updates :stuck_out_tongue: