Can't play MM3D restoration

Please forgive my stupidy, I realize the HD textures version needs an extra file, my apologies.

No matter what I try I can’t seem to get MM3D restoration to work on Citra. Every time I get to gameplay, Citra crashes and doesn’t let me play the restoration.
I’ve tried multiple different file types, I’ve tried different versions of the restoration, and I’ve tried different versions of Citra and I have no idea what’s going on.

  • Operating System: Windows 11 64 bit (shouldn’t make a difference)
  • CPU: Ryzen 7 2700x
  • GPU: GTX 1650
  • Citra Version: Nightly 1721, Canary 1986
  • Game: Majora’s Mask 3D Restoration

Diagnostic Log
Website was being wack so I’m gonna upload the log in the comments.

UPDATE: The non-HD textures version works but Citra doesn’t clear the texture cache for the game, so I still can play with the HD textures.

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

Website was still being wack so heres a Google Drive link:
https://drive.google.com/file/d/16rjGtW2qDbZN9fYc6M65ZNGa7kZK0C0c/view?usp=sharing

Does the game function without the mod/texture pack enabled?

Yes it does. I was just being stupid and forgot an extra file the HD textures version needed. Thanks for trying to help though.