Can't play Pokémon Ultra Sun due to infinite black screen

Issue: I just finished playing Pkmn Sword and now I’m trying to play Pkmn Ultra Sun on Citra, but when I tried to open it, it just stays on a black screen. The speed is always at 100%, but it also always registers 0 fps, and right after loading the shaders, the screen flashes a single time, then turns black indefinitely. I tried changing some graphical settings, changing from OpenGL to Software but nothing seems to work. Is this a common error? (all other Citra games work fine, I’m even a champion in Pkmn X)

System Information

  • Operating System: Windows 11
  • CPU: Intel Core i5-12500H
  • GPU: Nvidia GeForce RTX 3050-Ti (mobile)
  • Citra Version (found in title bar): Nightly 1973
  • Game: Pokémon Ultra Sun
  • Screenshot of Issue (include the full Citra window including titlebar):

(I’m sorry for any translation issues, my Citra is in Portuguese - if in doubt, feel free to ask)

Diagnostic Log
citra_log.txt (321.5 KB)

In order to save a copy of the log, follow this guide:

System Information for Support

Client Version                               Nightly 1973  HEAD-b2092de
Operating System                             Windows 11 Version 22H2 (Build 22621.2134)
CPU                                          12th Gen Intel(R) Core(TM) i5-12500H | AVX2 | FMA
Graphics API                                 OpenGL 4.3.0
Graphics Renderer                            NVIDIA GeForce RTX 3050 Ti Laptop GPU/PCIe/SSE2
GPU Driver Version                           528.79
CPU JIT                                      [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

I did not find anything wrong in your log file. Please wait for a human moderator to assist.

Citra appears to be running into something corrupted. Since you have a game update installed, (and perhaps a randomization/romhack?) either your game, or your patch may be corrupted. I would suggest redumping both just to be safe:

Dumping Game Cartridges
Dumping Installed Titles
Dumping Updates and DLC

Make sure your GM9 is up to date and that you have enough free storage space available on your SD-Card to perform the dump.

Sure, I’ll try something about it and will get back to you.