Can't start MH4 and MHXX (fatal error)

Issue:
I can’t start any of the games mentioned, it was starting fine last night and I just got home and it won’t start and kept showing (fatal error)

System Information

  • Operating System: Windows 10 Pro
  • CPU: Intel® Core™ i5-3320m CPU @ 2.70GHz
  • GPU: Intel HD 4000 (no dedicated)
  • Citra Version (found in title bar): 1550 (Nightly Build)
  • Game: MH4U/MHXX
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (16.0 KB)
In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Nightly 1550 HEAD-028609d
Operating System                              Windows 10 (10.0)
CPU                                                  Intel(R) Core(TM) i5-3340M CPU @ 2.70GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 4000
GPU Driver Version                            10.18.10.4885
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. https://downloadcenter.intel.com/product/80939/Graphics-Drivers
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

My GPU is already updated though.

Nah latest is 5129.

Download win64_15.33.50.5129.zip from https://downloadcenter.intel.com/download/29473/Intel-Graphics-Driver-for-Windows-15-33-?product=71257
direct link: https://downloadmirror.intel.com/29473/a08/win64_15.33.50.5129.zip

then follow this guide to install it: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/

Also do this:

  1. Open Citra then go to File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder if it’s there
  3. Emulation->Configure... then click on Graphics on the left
  4. Click on the Advanced tab and turn on Accurate Multiplication

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to slowly load all shaders from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.

I will give you the benefit of the doubt that you are not trying to run the “prepatched v4” rom which is broken and only pirates use it.

Oh ok thanks for the fast reply. I will be working on this and see if it works. Thanks for the update I was completely unaware of that update. I still have much to learn.

and BOOM it worked thanks! I checked my driver and kept saying that it has the latest but it wasn’t so I re-rolled the driver back and installed the latest version and it worked like magic.

1 Like