Can't use hardware renderer OpenGL


#1

Issue:
I see everyone use the hardware renderer option “OpenGL”. I seem to not be able to do that. I use Windows (bootcamp) on an iMac. My graphicscard supports up to openGL 4.1 and OpenCL 1.2.

Is it a common issue that Bootcamp-users can’t use this hardware renderer option.

Tell me what I should provide for extra information, please.


#2

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.


#3

what citra version are you using? also post your system specs (whi iMac, which windows version) also upload your log.


#4

That option was renamed a while back. It’s called Enable Hardware Shader now. It was explained in the Citra Progress Report 2018 Q1 progress report.


#5

Hi all, I’m on the latest version of macOS (10.13.6) and on the latest version of WIndows 10. This is my Citra log:
[ 0.003663] Config core/settings.cpp:LogSettings:52: Citra Configuration:
[ 0.003677] Config core/settings.cpp:LogSetting:48: Core_UseCpuJit: true
[ 0.003678] Config core/settings.cpp:LogSetting:48: Renderer_UseHwRenderer: true
[ 0.003679] Config core/settings.cpp:LogSetting:48: Renderer_UseHwShader: true
[ 0.003679] Config core/settings.cpp:LogSetting:48: Renderer_ShadersAccurateGs: true
[ 0.003680] Config core/settings.cpp:LogSetting:48: Renderer_ShadersAccurateMul: false
[ 0.003681] Config core/settings.cpp:LogSetting:48: Renderer_UseShaderJit: true
[ 0.003687] Config core/settings.cpp:LogSetting:48: Renderer_UseResolutionFactor: 0
[ 0.003738] Config core/settings.cpp:LogSetting:48: Renderer_UseVsync: false
[ 0.003740] Config core/settings.cpp:LogSetting:48: Renderer_UseFrameLimit: true
[ 0.003741] Config core/settings.cpp:LogSetting:48: Renderer_FrameLimit: 125
[ 0.003741] Config core/settings.cpp:LogSetting:48: Layout_Toggle3d: false
[ 0.003746] Config core/settings.cpp:LogSetting:48: Layout_Factor3d: 0
[ 0.003754] Config core/settings.cpp:LogSetting:48: Layout_LayoutOption: 3
[ 0.003757] Config core/settings.cpp:LogSetting:48: Layout_SwapScreen: false
[ 0.003759] Config core/settings.cpp:LogSetting:48: Audio_OutputEngine: auto
[ 0.003762] Config core/settings.cpp:LogSetting:48: Audio_EnableAudioStretching: true
[ 0.003765] Config core/settings.cpp:LogSetting:48: Audio_OutputDevice: auto
[ 0.003768] Config core/settings.cpp:LogSetting:48: Camera_OuterRightName: blank
[ 0.003770] Config core/settings.cpp:LogSetting:48: Camera_OuterRightConfig:
[ 0.003781] Config core/settings.cpp:LogSetting:48: Camera_OuterRightFlip: 0
[ 0.003782] Config core/settings.cpp:LogSetting:48: Camera_InnerName: blank
[ 0.003783] Config core/settings.cpp:LogSetting:48: Camera_InnerConfig:
[ 0.003785] Config core/settings.cpp:LogSetting:48: Camera_InnerFlip: 0
[ 0.003799] Config core/settings.cpp:LogSetting:48: Camera_OuterLeftName: blank
[ 0.003809] Config core/settings.cpp:LogSetting:48: Camera_OuterLeftConfig:
[ 0.003819] Config core/settings.cpp:LogSetting:48: Camera_OuterLeftFlip: 0
[ 0.003830] Config core/settings.cpp:LogSetting:48: DataStorage_UseVirtualSd: true
[ 0.003831] Config core/settings.cpp:LogSetting:48: System_IsNew3ds: false
[ 0.003832] Config core/settings.cpp:LogSetting:48: System_RegionValue: -1
[ 0.003846] Config core/settings.cpp:LogSetting:48: Debugging_UseGdbstub: false
[ 0.003856] Config core/settings.cpp:LogSetting:48: Debugging_GdbstubPort: 24689
[ 0.098666] Input input_common/udp/client.cpp:StartCommunication:199: Starting communication with UDP input server on 127.0.0.1:26760
[ 0.363716] Frontend citra_qt/main.cpp:GMainWindow:152: Citra Version: Canary #739 | HEAD-276b0a2
[ 0.380458] Service.FS core/file_sys/ncch_container.cpp:Load:175: Secure1 KeyX missing
[ 0.380464] Service.FS core/file_sys/ncch_container.cpp:Load:189: Secure2 KeyX missing
[ 0.380472] Service.FS core/file_sys/ncch_container.cpp:Load:271: NCCH is marked as encrypted but with decrypted exheader. Force no crypto scheme.
[ 0.447629] Frontend citra_qt/main.cpp:CheckForUpdates:558: Update check started
[ 1.888133] Frontend citra_qt/main.cpp:OnUpdateFound:571: No updates found
[ 3.099510] Input input_common/udp/protocol.cpp:Validate:34: Invalid UDP packet received
[ 3.099532] Input input_common/udp/protocol.cpp:Validate:34: Invalid UDP packet received
[ 6.099420] Input input_common/udp/protocol.cpp:Validate:34: Invalid UDP packet received
[ 6.099435] Input input_common/udp/protocol.cpp:Validate:34: Invalid UDP packet received
[ 9.099613] Input input_common/udp/protocol.cpp:Validate:34: Invalid UDP packet received
[ 9.099629] Input input_common/udp/protocol.cpp:Validate:34: Invalid UDP packet received
[ 12.099308] Input input_common/udp/protocol.cpp:Validate:34: Invalid UDP packet received
[ 12.099323] Input input_common/udp/protocol.cpp:Validate:34: Invalid UDP packet received
[ 15.099272] Input input_common/udp/protocol.cpp:Validate:34: Invalid UDP packet received
[ 15.099289] Input input_common/udp/protocol.cpp:Validate:34: Invalid UDP packet received
[ 18.099391] Input input_common/udp/protocol.cpp:Validate:34: Invalid UDP packet received
[ 18.099410] Input input_common/udp/protocol.cpp:Validate:34: Invalid UDP packet received
[ 21.099296] Input input_common/udp/protocol.cpp:Validate:34: Invalid UDP packet received
[ 21.099311] Input input_common/udp/protocol.cpp:Validate:34: Invalid UDP packet received
[ 24.099366] Input input_common/udp/protocol.cpp:Validate:34: Invalid UDP packet received
[ 24.099383] Input input_common/udp/protocol.cpp:Validate:34: Invalid UDP packet received
[ 27.099802] Input input_common/udp/protocol.cpp:Validate:34: Invalid UDP packet received
[ 27.099818] Input input_common/udp/protocol.cpp:Validate:34: Invalid UDP packet received


#6

@Cavier turn off Enable Hardware Shader.
it is broken on macos.


#7

As I stated before, i’m not on Mac when running Citra. I’m on Windows (bootcamp) running Citra.


#8

What exactly happens when you try using the hardware shader? Is it crashing?


#9

I want to use the hardware renderer option I see others use. I’ve learnt that option is replaced by the “Hardware shader” en “hardware render” tickboxes in the latest builds. Correct?


#10

Yep. You can read more about the change here.