Can't work on my PC Win 10 64bit

#1

Issue:
I tried to play Mario and Luigi Superstar Saga 3ds and gave an error.

System Information

  • Operating System: Win 10 64bit
  • CPU: Intel Core i5
  • GPU: Intel HD Graphics 3000
  • Citra Version (found in title bar): HEAD-3bd1cd0
  • Game: Mario and Luigi Superstar Saga + Bowser Minions (EUR)

Log:

Paste your entire console window log here.
[ 1.832577] Frontend citra_qt/main.cpp:OnUpdateFound:516: No updates found
[ 10.786054] Frontend citra_qt/main.cpp:BootGame:642: Citra starting…
[ 10.915716] Render.OpenGL video_core/renderer_opengl/renderer_opengl.cpp:Init:488: GL_VERSION: 1.1.0
[ 10.915730] Render.OpenGL video_core/renderer_opengl/renderer_opengl.cpp:Init:489: GL_VENDOR: Microsoft Corporation
[ 10.915733] Render.OpenGL video_core/renderer_opengl/renderer_opengl.cpp:Init:490: GL_RENDERER: GDI Generic
[ 10.915750] Render video_core/video_core.cpp:Init:34: initialization failed !
[ 10.915765] Core core/core.cpp:Load:110: Failed to initialize system (Error 9)!
[ 177.304115] Frontend citra_qt/main.cpp:BootGame:642: Citra starting…
[ 177.343514] Render.OpenGL video_core/renderer_opengl/renderer_opengl.cpp:Init:488: GL_VERSION: 1.1.0
[ 177.343525] Render.OpenGL video_core/renderer_opengl/renderer_opengl.cpp:Init:489: GL_VENDOR: Microsoft Corporation
[ 177.343528] Render.OpenGL video_core/renderer_opengl/renderer_opengl.cpp:Init:490: GL_RENDERER: GDI Generic
[ 177.343537] Render video_core/video_core.cpp:Init:34: initialization failed !
[ 177.343574] Core core/core.cpp:Load:110: Failed to initialize system (Error 9)!

In order to save a copy of the log, follow this guide: How to Upload the Log File

#2

Your iGPU is too old. It supports up to OpenGL 3.1, while Citra requires 3.3. Unfortunately, the only way to solve this is to buy either a new laptop (if you have one) or buy a dedicated GPU for your desktop.

#3

This seems to be one of the most frequent issues. I wonder if a list of iGPU chips that don’t support OpenGL 3.3 in the F.A.Q. somewhere, that can be linked to, would be beneficial. (Or even better, if Citra could detect that more gracefully and inform the end user)

#4

I know a Intel website that lists the maximum OpenGL version for all models

1 Like
#5

However, on Linux, this supports upto 3.3, so you can use Linux & you’ll be alright.

#6

Thank you for the reply

#7

Thank you for the reply.