Character Graphic Glitches when play Fire Emblem Awakening

Issue:
Enter a description of your issue here, in full detail.

System Information

  • Operating System: Windows 10 Enterprise
  • CPU: Intel Core i5-3337U CPU @ 1.80 GHz
  • GPU: AMD Radeon HD 8500
  • Citra Version: Citra Nightly 1588
  • Game: Fire Emblem Awakening
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (89.1 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Nightly 1588 HEAD-f4e727c
Operating System                              Windows 10 (10.0)
CPU                                                  Intel(R) Core(TM) i5-3337U CPU @ 1.80GHz
Graphics API                                  OpenGL 3.3.1
Graphics Renderer                             AMD Radeon HD 8500M Series
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Download and install Adrenalin 2020 Edition 20.7.1 from https://www.amd.com/en/support/graphics/amd-radeon-hd/amd-radeon-hd-8000m-series/amd-radeon-hd-8570m-series-gpu, select Factory Reset in the installer under Additional Options to make sure you start with clean drivers.

Also do this:

  1. Open Citra then go to File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder if it is there.
  3. Emulation->Configure... then click on Graphics on the left
  4. Click on the Advanced tab and turn on Accurate Multiplication

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to load all shaders slowly from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.