Character in Pokemon Ultra Sun is unable to run

Issue:
As issued in the title the Character is unable to run. Went pressing “B” and a direction the Character simply stands still. This also happens when riding on Tauros (and probably the other pokemon but havn’t unlocked any other) where you even see that Tauros is making the animation that it’s ready to charge but isn’t moving an inche. It’s probably the same problem as here, but since it’s a different game I made a separate topic

System Information

  • Operating System: Windows 10
  • CPU: Intel Core i7 - 7700HQ 2.80GHz
  • GPU: NVIDIA GeForce GTX 1060
  • Citra Version (found in title bar): Citra Nightly 767
  • Game: Pokemon Ultra Sun
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (217.8 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

playing on Canary #591.
all working like a charm, except the sensors for Portal flight(didnt think they are implemented).

have u tried another version of citra?

1 Like

right click and drag on the screen for gyro controls.

are you aware that keyboards often have a limit to simultaneous keys pressed? https://gaming.stackexchange.com/a/6671 I’m not positive this is what you are running into right now, but nothing about your hardware configuration suggests that there should be an issue. If you are using a controller, double check that you used the “Set Analog Stick” option when configuring up/down/left/right.

The keyboard isn’t the problem since I am able to run in pokemon super mystery dungeon and Etrian Odyssey Untold in the newest citra nightly version. Maybe I just have a brocken rom. I will download another and give it a try again.

ah good to know. tyvm
played this step on my 3ds and copied the save back to citra :slight_smile:

Piracy isn’t supported here. Dump your games from a 3DS.

I had this same issue, in my case it was because I had configured wasd for actions and left right up down for movement, the B key was assigned to D in my keyboard, it seems that my keyboard was limiting binding the movement keys with D when both were pushed at the same time, its possible that the combination is limited because they’re commonly used for the same purpose (D tends to be move right), after changing it to F or any other not wasd key, it worked fine.