Citra always either says it can't detect an SD card, or gets stuck on launching

Whenever I try to get Persona Q to open on Citra, it says, “Map data for Persona Q is saved on the SD Card. If no SD Card is inserted, Map data will not be saved.” It is then stuck there, not doing anything else. I saw on other threads that enabling/disabling VSync and the GDB Stub could fix this issue, but I’ve had no luck with everything I tried. That being…

VSync Disabled, GDB Stub Disabled: SD Card Error

VSync Enabled, GDB Stub Disabled: SD Card Error

VSync Disabled, GDB Stub Enabled: Stuck on Launching

VSync Enabled, GDB Stub Enabled: Stuck on Launching

I’m hoping this issue can be resolved swiftly. I’m not too experienced with decrypting and such, so getting the actual game to be compatible with Citra was already time-consuming for me. XD

System Information

  • Operating System: Windows 11 Home
  • CPU: Intel(R) Core™ i5-10300H CPU @2.50GHz
  • GPU: Intel(R) UHD Graphics [GPU 0] & NVIDIA GeForce GTX 1650 Ti [GPU 2]
  • Citra Version (found in title bar): Citra Nightly 1859 for PC
  • Game: Persona Q - Shadow of The Labyrinth
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & droppingTor to save a copy of the log, follow this guide:
citra_log.txt (16.6 KB)

Please tell me which threads gave you that information. I’d like to go and purge those immediately.

As for the issue, please properly redump your game using our dumping guides (don’t use PC decrypters, it just adds more points for failure). Refer to our game dumping guides:

Dumping Game Cartridges
Dumping Installed Titles

Make sure your GM9 is up to date and that you have enough free storage space available on your SD-Card to perform the dump.

Hi SleepingSnake,

I have tried to relocate the threads I mentioned, but I haven’t been successful. I don’t think that both of them were on here though.

It is true that I used a PC decrypter with no success, and I remember I tried using Citra years ago with different roms that had similar results if I remember correctly. Whilst I do own a 3DS, its been a long time since I’ve actually used it, and I have no idea where it is. :confused: So if a 3DS is required to decrypt a ROM file successfully without this SD card error I’m getting, I’m starting to question what the point of trying to emulate it with Citra is when I can just buy the game and play it on a 3DS.

I do apologize if my lack of experience with Citra and 3DS Roms comes off the wrong way though. I am grateful for your quick response and look forward to finding a way to play this and other games one way or another. Thank you.

An emulator is an extension of your 3DS experience for the purposes of enhancement (like with texture packs and mods) and preservation. It’s not an alternative for pirating console games. You are legally required to buy and dump the games you wish to emulate. That’s the only legal way to obtain ROMs for use in Citra. So that is the only way that we’ll support users with. Your comment heavily insinuates that you did not obtain the game you’re trying to run legally, which means that at this time, I cannot provide any more support to you until you’ve provided proof of having dumped the game properly.

Please upload a photo of your 3DS in GM9 whilst selecting your game for dumping. After that, I can provide support once more.

As for how to set up your 3DS for dumping, please refer to this guide:

After you’re done with that guide, these guide will help you with the dumping process:

Dumping Game Cartridges
Dumping Installed Titles