Citra android game crash after 1-2 minutes

Thanks it worked. I really thought that those shaders were because of the progress I’ve made. Now I can continue my game.

Well, they are because of the progress you’ve made, but phones tend to not have as much RAM as desktop devices have. This means that whilst desktop devices can cope with that amount of shaders, not all phones would necessarily be the same. Only a few games have that many shaders to generate though. So this is normally more the exception rather than the norm.

If Citra starts crashing again in the future, you can delete the opengl folder again. You’ll need to suffer through shader stutter again every time you delete the cache, but it’s better than having no cache at all in the end.
Maybe we need to create some sort of garbage collector, that gets rid of cached shaders that aren’t used often or something similar…

1 Like

I completed the game up to pokemon league with no problems. Since after the parade (Pokemon Y), when I open the game, as soon as I enter a pokestop or any other house, or even when I open my backpack, the game crashes. I have a Xiaomi Redmi note 10 pro

citra_log.txt (1.1 KB)

The log file is incomplete. Please follow these steps carefully:

  1. Restart the Citra app if it’s already running.
  2. Launch your game and encounter the problem.
  3. Shut down the Citra app (do not restart Citra as that will wipe the log file of important information!).
  4. Navigate to Internal Storage/citra-emu/log and upload the citra_log.txt file in this chat.

Hi I have the same issue I cannot complete the game Zelda a link between worlds the app it crashing
citra_log.txt (67.7 KB)
citra_log.txt.old.txt (2.5 MB)

Disable your cheat, then restart the emulation. Now try your game again. See if the same issue occurs.

Hi please how can I disable the cheats?

Head to Internal Storage/citra-emu/cheats and either delete the 00040000000EC300.txt file found here. Or open the file with a text editor and remove the *citra_enabled line before the code and save it.

Hi still the problem remains , still application is crushing
citra_log.txt.old.txt (1.8 MB)
citra_log.txt (1.0 MB)

Hmm, go to Internal Storage/citra-emu again, and rename the nand folder here to nand edit. Restart Citra, then try your game again, if the same issue occurs, upload a new log file.

Thank you soooooo much it’s working now :grin::grin:

I’m glad that worked for you, however given your screenshot, it appears that you’re using an unofficial build. Please note that we don’t provide support for those here generally speaking. The nand suddenly corrupting on you is probably related to that as well.

1 Like

Noted thank you so much I will delete this version :pray::pray:

citra_log.txt (2.1 KB)
citra_log.txt.old.txt (6.6 KB)
How about this?

Hmmm, please try the latest Citra Canary build: Releases · citra-emu/citra-canary · GitHub

I was playing on android. So what should I do?

Download the .apk from the latest Canary version and install it?

Now I got these
citra_log.txt (2.1 KB)
citra_log.txt.old.txt (6.6 KB)

Please double check the Citra version that you’re using. Those log files are not from the latest Citra Nightly or Canary build.

what do you mean by that