Citra Android: Razer Kishi B-button Always Tied to "Close Game?"

Issue:
When configuring my Razer Kishi for Citra Android, I am unable to map the B-button, as it always treats it as “escape” or “back”.
Would like the option to disable this, or if not, make this button the Xbox button/not one of the face buttons.

System Information

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

it is the fault of controller i guess…

1 Like

I also use a Razer Kishi and am having this exact same problem! I would absolutely love for someone to find a solution to this I am happy to provide a log if necessary.

1 Like

ps4 controller on nvidia shield tv pro/Android/Google tv, same problem.

also, unable to hide button overlays from Android tv interface.

I am also having this exact same problem. Every other emulator I run on Android works fine with the Razer Kishi but not Citra. B button wants to close the game even when I have it mapped in the gamepad settings. It’s the only button I’ve found that doesn’t behave properly.

My Galaxy S20 is on Android 11 if it helps.