Citra Android running much slower, seemingly out of the blue

Issue:

Like the title says, out of nowhere, Citra on Android just started running significantly slower. I had been using the MMJ build for the past 2 weeks, and it was working flawlessly. I use an LG V60, and it has been great for emulation. However, just yesterday, ROMs have been running at 15-20 fps instead of the consistent 30. I have tried a multitude of different things to fix this, from making sure my device is charged to making it cold (LG has aggressive thermal throttling). I’ve tinkered with settings, re downloaded the build, tried different builds, used different ROMs. Nothing runs as fast as it did a week ago. I haven’t had any software updates. It’s truly bizarre.

Im at a loss. When everything was working great, I had x3 resolution at 29-30fps. I didn’t even have to change any settings, at the time, I was using whatever default the MMJ build had. If anyone can fix this, idk I’ll buy you a pizza or something. I’m just baffled as to why it would do this out of nowhere

System Information

  • Operating System: Android
  • CPU: Snapdragon 865
  • GPU: idk, 8gb of ram
  • Citra Version (found in title bar): Android Build - 57aad68
  • Game: All of them, but the one I’ve played most is Pokemon Sun

Log does not want to upload from my Android device:(

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

We only support Citra Android that is from the Play Store or from: https://github.com/citra-emu/citra-android/releases

You can try bisect the issue by using the link above where you can download older builds.

The build I downloaded was from the website, is that not considered official unless it’s the play store? Also, I did use the play store version as well just now, but it seems to have the same lag. The fps doesn’t want to go above 18. I wish I had more info to provide. Is there anything you could request of me?

Or well that too, forgot to mention that :stuck_out_tongue: however it takes you to the Play Store when you are on Android.

However you mentioned “MMJ” which is not official.

Download the older builds from github to bisect the issue (find which build caused the problem).