Citra Android Version Can't Dump System Archives

This is the source code: https://github.com/SachinVin/citra_android

I’m trying to dump the system archives but I’m not 100% sure where the files are stored on my phone. I’m browsing through the files right now on Windows and i found a folder named citra-emu which only has 2 folders in it; the config folder and the log folder. So i tried copying the nand, sdmc, and sysdata folder from my PC to this citra-emu folder and I can’t seem to do so. It doesn’t even give me any error message, just that usual windows error sound effect. At first i thought it was some permission issues but it doesn’t seem so. I tried copying these 3 folders to some random folder on my phone and it works. Tried copying a random txt file to citra-emu and it works. It’s just these 3 specific folders that can’t be copied. Is this not the correct folder for it?

System Information

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.