Citra Assertion error

Issue:
Enter a description of your issue here, in full detail.
Hi! The emulator crashes as soon as I load a game.

System Information

  • Operating System: Windows 7, x64 (Not a VM)
  • CPU: Intel(R) Celeron(R) CPU G540 @ 2.50GHz (2 cores)
  • GPU: NVIDIA GeForce GT 520 (OpenGL 4.1)
  • Citra Version (found in title bar): Nightly 1782
  • Game: Minecraft - New Nintendo 3DS Edition (USA) (Decrypted).3ds
  • Screenshot of Issue:

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

citra_log.txt.old.txt (7.7 KB)

Oh boy. That is some real potato level hardware. Hmmm. Try disabling Accurate Multiplication in Emulation>Configuration>Graphics>Advanced Tab.

Well that doesn’t work. Any other ideas?

I ran Citra via the command line. It shows this:

Yea, the driver is shitting itself, same thing is shown on the qt log file. That’s why I thought Accurate Multiplication might be the culprit. Since old GPU drivers really don’t know how to handle using it.

Since that didn’t solve the issue, lets make sure that the driver is up to date for sanity’s sake: GeForce Game Ready Driver | 391.35 | Windows 7 64-bit, Windows 8.1 64-bit, Windows 8 64-bit | NVIDIA

Also, that GPU should be able to run the latest Citra builds (on paper anyways, fermi has always been a bit weird with documentation). Try updating to the latest Citra build(s).

Alright, I’m downloading the driver updater. Welp, gotta wait 30 mins! BRB.

Also, I ran the latest Citra build already. Didn’t work, it said “Your GPU may not support OpenGL 4.3”, and Citra’s right. I have OpenGL 4.1.2 . I hope this driver fixes everything! I hate it when the driver ****s itself.

Nope! Didn’t work. But that driver fixed the Shader not Linked error. The only thing that happened:

That error is usually associated with a badly built ROM. Have you patched the ROM in any way? If not, it can just be a poor dump. Either way, I would suggest a redump. Please refer to our game dumping guides:

Dumping Game Cartridges
Dumping Installed Titles

Make sure your GM9 is up to date and that you have enough free storage space available on your SD-Card to perform the dump.

No. I haven’t patched the ROM. I guess, this is it! Thanks for the help once again! God bless you :heart:

1 Like