Citra blank error message on Qt application launch

Issue:
Before the full Citra window is presented, I get an empty warning window. On pressing OK Citra launches normally.

The issue happens with the install application too.

Also with other Qt applications as transmission, but not Dolphin or RetroArch or qBittorrent that use more recent Qt.

I tried to search the issue and the closest one I could find was related to qwindows.dll missing error if it is pre-set in environment path. I don’t have QT_PLUGIN_PATH.

I examined hooked dlls while the error message is displayed and the same issue happens with the Antivirus disabled, also Windows Resource Protection did not find any integrity violations.

System Information

  • Operating System: Windows 10 x64 v1903
  • CPU: Intel Core i7 7500U
  • GPU: Intel HD 620 / Nvidia GTX 1050 4GB
  • Citra Version: Citra Nightly 1372
  • Game: NA
  • Screenshot of Issue:
    error

Diagnostic Log
I don’t know if Citra log applies here since it runs correctly, but I will include it if needed.

#C:\Users\Tifa>echo %QT_PLUGIN_PATH%
#%QT_PLUGIN_PATH%

#C:\Users\Tifa>echo %PATH%
#C:\Program Files (x86)\Common Files\Oracle\Java\javapath;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0;C:\Program Files\NVIDIA Corporation\NVIDIA NvDLISR;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0;C:\WINDOWS\System32\OpenSSH;C:\Users\Tifa\AppData\Local\Microsoft\WindowsApps;

listdll.log (18.7 KB)

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

This behaviur happens with the latest VCRUNTIME140.dll v14.23.27820.0 in System32, I tried the version linked in Citra faq (14.11.25325.0) but the same message appears.

The only solution I found was renaming VCRUNTIME140.dll to VCRUNTIME140.dll.bak and the message disappears, the apps still use another older dll provided by the system it seems. This rename workaround didn’t fix the problem with Citra setup file or 32 bit older Qt applications, renaming the dll in SysWOW64 simply makes it unavailable.

The later versions of VCRUNTIME140.dll in Windows 10 x64 1903 appear to have an inconsistent behaviour with older Qt apps vs newer framework, If my guess is right.

Edit after pinpointing the offending service with a series of cleanboots using msconfig, a corrupt driver install for my wacom pen was the culprit. A reinstall fixed this system wide conflict that affected all Qt applications using older variants of the framework.