Citra (Both Canary and Nightly versions) low FPS and frequent dropping

Issue:
Hey everyone, whenever I am using Citra either on Canary or Nightly I encounter frequent fps drops as well as that my fps will stay on an average of 15 FPS without Hardware shader, with enabled Shader Jit and disabled v-sync, I will experience drops but not as significant with having the Hardware shader on with accurate multiplication, I receive the expected amount of 30 FPS, but I will experience large frequent drops. FYI, the average is usually when I am walking around and I will usually experience drops when talking to an NPC and throwing out a pokemon into battle.

System Information

  • Operating System: Mac OS
  • CPU: 1.6 GHz Dual-Core Intel Core i5
  • GPU: Intel UHD Graphics 617 1536 MB (Integrated)
  • Citra Version (found in title bar): Citra Nightly 1766
  • Game: Pokemon Alpha Sapphire, Pokemon X and Pokemon Ultra Moon.
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (242.8 KB)

System Information for Support

Client Version                               Nightly 1766   HEAD-a6e7a81
Operating System                             macOS 12.4
CPU                                          Intel(R) Core(TM) i5-8210Y CPU @ 1.60GHz | AVX2 | FMA
Graphics API                                 OpenGL 4.1
Graphics Renderer                            Intel(R) UHD Graphics 617
GPU Driver Version                           ?
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [ ]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                3
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

  • Please enable the Vsync option if you are experiencing screen tearing.

I’ve tried using V-sync before and it has not made any other effects except for increasing the FPS to around 60 when I start up the game but no other time.

Please enable Hardware Shaders again, you’ll get better performance with that (Citra > Preferences > Graphics > Advanced).
Other than that, your hardware is below our recommended minimum for good gameplay so this is to be expected.

Ok, thanks for the help.