Citra Canary doesn't open on Mac Catalina after today's update. It worked fine until then

Issue:
Citra Canary not opened “because of a problem”

System Information

  • Operating System: MacOSX Catalina 10.15.5
  • CPU: 2,6 GHz 6-Core Intel Core i7
  • GPU: AMD Radeon Pro 5300M 4 GB Intel UHD Graphics 630 1536 MB
  • Citra Version (found in title bar): Canary, Can’t even open, but it was today’s (22 Oct) Update
  • Game: •••
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Log wasn’t able because citra didn’t even open. Pasting details from apple’s dialog:

Process: citra-qt [3130]
Path: /Applications/CitraC/*/citra-qt.app/Contents/MacOS/citra-qt
Identifier: com.citra-emu.citra
Version: ??? (???)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: citra-qt [3130]
User ID: 501

Date/Time: 2020-10-22 11:52:29.725 +0200
OS Version: Mac OS X 10.15.5 (19F96)
Report Version: 12
Bridge OS Version: 4.5 (17P5290)
Anonymous UUID: 20C1CC69-5EE6-A799-A8E4-54D9DDA4FA0E

Sleep/Wake UUID: 7EF1D891-B8BE-433C-8D90-DB0464C9DA45

Time Awake Since Boot: 9200 seconds
Time Since Wake: 980 seconds

System Integrity Protection: enabled

Crashed Thread: 0

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000
Exception Note: EXC_CORPSE_NOTIFY

Termination Reason: DYLD, [0x1] Library missing

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
Library not loaded: @rpath/libc++abi.1.dylib
Referenced from: /Applications/CitraC/canary/citra-qt.app/Contents/Frameworks/libc++.1.0.dylib
Reason: image not found

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

I was not able to find the log file in my mac.
Not even searching for the file name.

Is there any way I can revert the install to an older version? The rom I was using doesn’t run on Nightly

Okay, so, apparently, there’s nobody willing to at least answer. Is anything else I can do to help the developer reach a fix? Is the answer not coming because it’s a mac issue? Should I just give up?

Well I didn’t asnwer because I’m not at all familiar with MacOS. The mac builds in general have bunches of weird stuff happening all the time, making diagnosing a problem nigh impossible for me.

Try downloading this citra-osx-20201004-1c8461f.tar.gz and unpack it, then inside the unpacked folder, create a folder called user in the same place that you can find citra-qt.
Now try running citra-qt.

2 Likes

It worked, even though this is the nightly, right?
Thank you.

I am having the same problem, and it is not working. Do I make the user folder in the unpacked folder, or in another folder?

In the unpacked folder