Citra can't run on this PC"

Issue:
Every time I try open Citra, a pop-up message always appear saying that "this app can’t run on your pc. I tried opening it normally and also tried opening it as an an admin. but the same result always happens. I use a windos 10 x86.

System Information

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

“x86” = 32-bit. Citra is a 64-bit(x64) application, update your OS to 64-bit.

is that so? right now I don’t have the time to update my OS but I might update it later but is ther a version of Citra that can run on x32 bit? thank you!

Sorry there is none, 32-bit has been phased out for a long time. All processor made in the last 10 years support 64-bit. I think the last Intel CPU that was strictly 32-bit was Pentium 4(earlier models).

32-bit also has restrictions such as only being able to have 4GB RAM.

Thank you then, well, it’s worth the try…