Citra closes after ~6 seconds with no error pop ups

Issue:
Citra-qt (Canary 1382) auto closes ~6 seconds after start up.

It doesn’t show any error messages or “not responding”.
I can’t access anything. I can’t access menu bar panels and ROMs. If I try to load up ROMs, it just waits out a few secs and then it closes. I try to go to Emulation>>Configure (or any other menu bar panels) but it just freezes for a few seconds and closes afterwards.

Everything was fine a few hours ago. I was playing Pokemon Ultra Sun and I thought that the motion controls with Right Click felt hard to control for the Ultra Wormholes sections. So I googled and found out that I can use an android phone together with the “MotionSource” mobile app and the “pad test” for PC. I didn’t bother to look up a tutorial on how to operate it but I just basically tried to input the same IP thingies and server on the “padtest (PC)” and Citra’s motion control 2nd selection “Cemuhook”. After that, Citra just froze and closed afterwards. Seems like I failed badly. The problem stated above started occurring.

I saw a few posts saying that Citra crashes with no crash logs when certain controllers are connected to the PC. I’m not even sure how to do that since in my case it’s just server/client type of controller. I turned off the server on my phone, even uninstalled it and even turned my phone off. I did the same to my PC. I deleted the padtest program and restarted my PC. After all that, the problem still persists.

I tried a different Canary build, the Canary 1378 and same results. I tried running up the Citra installer and installed it into a new directory folder, same results.
I did a system restore but it said it didn’t complete the restoration. I’m not even sure if system restore can help, but I did it anyways. That said, I’ll try to do another system restore after this writing this post.

I’m scared that I might lose my progress and everything in the process, but I just want the emulator to work again.
Thank you very much in advance.

System Information

  • Operating System: Windows 10
  • CPU: Intel® Core™ i7-6500U CPU @ 2.50GHz (4 CPUs), ~2.6GHz
  • GPU: NVIDIA GeForce 940MX
  • Citra Version (found in title bar): Canary 1382 / Canary 1378

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

Close citra, open the C:\Users\%username%\AppData\Roaming\Citra\config folder and delete the ‘qt-config.ini’ file. this will reset citra settings,

Follow the “Android MotionSource server” guide here:
https://cemuhook.sshnuke.net/padudpserver.html

1 Like

I thought of messing around with some sort of config file using notepad, but I couldn’t find it. Turns out it’s located to the directory you just said. It worked! Thank you so much!