Citra couldn't load camera in preview

So basically, I restarted my computer recently, and I opened citra like any other day. Except there was a little problem because when I tried to set my camera to rear and clicked preview, it just said “couldn’t load camera”. I can still click ok and in game it will just show a black screen. I have also checked my camera settings and my camera can be opened by other apps such as discord or zoom (which I tested). The only problem I’d see here is that I don’t actually have a rear camera and when it worked, the camera it used for “rear” was actually the front one.

System Information

  • Operating System: Windows 11
  • CPU: Intel(R) Core™ i7-8565U CPU
    GPU: GeForce GTX 1050
  • Citra Version (found in title bar): Citra Nightly 1757
  • Game:
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (5.8 KB)

No game was booted in your log. If you are experiencing a crash then do not open citra again until after you posted the log as it gets purged when you reopen citra.
For more information, see How to Upload the Log File

Actually front camera doesnt work in preview either.

citra_log.txt (76.1 KB)

System Information for Support

Client Version                               Nightly 1757   HEAD-ac98458
Operating System                             Windows 10 (10.0)
CPU                                          Intel(R) Core(TM) i7-8565U CPU @ 1.80GHz | AVX2 | FMA
Graphics API                                 OpenGL 3.3.0
Graphics Renderer                            NVIDIA GeForce GTX 1050 with Max-Q Design/PCIe/SSE2
GPU Driver Version                           496.13
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

I did not find anything wrong in your log file. Please wait for a human moderator to assist.

In your screenshot, it shows that the camera selected for System Camera (qt) is <Default>. Are you sure that you cannot manually select your Camera’s model there?

Nope it doesnt show any other camera

Odd, it should show up there if Citra detects the camera. Which means it’s safe to assume that Citra isn’t seeing your camera. Is it a built in webcam? Or a separately connected camera (USB)?

Its a built in webcam

nvm fixed it by installing canary