Citra crash(closes) on monster hunter generations

Issue:
Enter a description of your issue here, in full detail.
citra closes on monster hunter generations everytime i go to palicho town

System Information

  • Operating System:Windows 10 Pro 64-bit
  • CPU: Intel Core i7 6600U @ 2.50GHz 49 °C
    Skylake-U/Y 14nm Technology
  • GPU: Intel® HD Graphics 520 (Lenovo)
  • Citra Version (found in title bar):citra nightly 1535
  • Game: Monster Hunter Generations
  • Screenshot of Issue (include the full Citra window including titlebar):


Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (26.7 KB)
In order to save a copy of the log, follow this guide:

System Information for Support

Client Version                                Nightly 1535 HEAD-41bff0e
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i7-6500U CPU @ 2.50GHz
OpenGL Vendor                                 Intel
OpenGL Renderer                               Intel(R) HD Graphics 520
OpenGL Version                                3.3.0
GPU Driver Version                            20.19.15.4424
Enable CPU JIT                                [x]
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

i enabled accurate multiplication but still didnt work game closed again

GPU Driver Version: Build 20.19.15.4424

This driver is outdated, you need to update.

Download igfx_win10_100.8141.exe from https://downloadcenter.intel.com/download/29530/Intel-Graphics-Windows-10-DCH-Drivers?product=88194
direct link: https://downloadmirror.intel.com/29530/a08/igfx_win10_100.8141.exe

Install it by following the steps on the Intel page regarding removing OEM customizations.

Also do this:

  1. File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to load all shaders from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.

Keep accurate multiplication enabled.

hmm i tried the second solution n deleted opengl game still crashed deleted it several times even deleted shaders it didnt work

The second thing is only to prevent other crashes in the future. You need to update drivers first.

Upload a new log so we can see if the new drivers are installed.

Did Intel’s steps help? If not we will need to update to 6373 drivers first in order to install 8141

the steps r a bit complex im not really that good with tech n it said i should delete drivers thats what im afraid of

i tried installing n got an error message

Ok, I suppose we go 6373 route first.

Download win64_25.20.100.6373.zip from https://downloadcenter.intel.com/download/28289/Intel-Graphics-Driver-for-Windows-10
direct link: https://downloadmirror.intel.com/28289/a08/win64_25.20.100.6373.zip

then follow this guide to install it: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/

After that you should be able to install 8141

i followed the steps n installed the driversthnk u so much the game load palicho town now

1 Like