Citra crash during qr scan in pokemon moon

Issue:
I was trying to qr scan in pokemon moon but it crashes after the popup window appears.

Earlier, i could do this normally without any hassle nor crash. But as soon as I made some changes in my computer it started to malfunction. I’m not sure which change caused the problem but they were:

  • List item
    I tried fixing an undetected external hard drive that i have and installed a paragon driver for windows (HFS4WIN). But after I restarted, i was not able to properly boot my computer. It undergo auto repair and I tried restarting, continuing to windows 10, turning off the computer, and finally, run a startup repair which fixed the problem of computer unable to properly boot.

I played pokemon moon again and tried to qr scan but now, i wasn’t able to load an image. It showed an old pop up window (like in the screenshot, and not like the windows 10 pop-up window.) and after around 10 seconds it hang a little and showed a pop up with a title bar of Microsoft visual C++ telling something about runtime causing the application to stop, something like that. I wasn’t able to screenshot it. Sorry :frowning:

  • List item
    Since I saw it was a problem involving runtime and visual C++ i tried to install the latest version of it in microsoft. After that it now just straight up crash like in screenshot without any notice at all.

System Information

  • Operating System: Windows 10 Education
  • CPU: Intel® Core™ i7-6500U
  • GPU: NVIDIA GeForce 940 MX
  • Citra Version (found in title bar): Citra Canary | HEAD-f69feeb
  • Game: Pokemon Moon

Diagnostic Log
citra_log.txt (23.0 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

This seems to be a recent regression:

1 Like

Thanks, I thought it was something i did in my computer.

That doesn’t sound like it. You’re using the Still Image option. That regression is for System Camera (qt) option. If this happens with the same build that worked before and you didn’t update, then it sounds like it’s an issue with your PC and not a regression.

Update the build, I’m now on Canary | HEAD a5a950f, still can’t use still image option. But now, it doesn’t crash anymore, it only shows black screen and I can continue the game if i pressed back. If this is an issue with my computer, what can you suggest me to fix this?

Tried reinstalling Citra, didn’t fix the problem. it seems that the problem really is in my computer.