Citra crash (Need help with the log file)

Issue:
Citra keeps not responding, and crashes when I open Pokemon Sun.

System Information

  • Operating System: Windows 7 Professional
  • CPU: Intel ® Core™ i5-3230M CPU @ 2.60GHz
  • GPU: Intel® HD Graphics 4000
  • Citra Version (found in title bar): Citra Canary 1775
  • Game: Pokemon Sun
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (6.2 KB)

System Information for Support

Client Version                                Canary 1755 HEAD-41dc0b7
Operating System                              Windows 7 SP 1 (6.1)
CPU                                                  Intel(R) Core(TM) i5-3230M CPU @ 2.60GHz
Graphics API                                  OpenGL ?
Graphics Renderer                             ?
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Hm, turn off Hardware Renderer then try start the game and when you close Citra upload a new log. We should be getting more information if you do that.

It worked a little,

. But it still crashed. Thank you for the fast respond though!
citra_log.txt (9.4 KB)

System Information for Support

Client Version                                Canary 1755 HEAD-41dc0b7
Operating System                              Windows 7 SP 1 (6.1)
CPU                                                  Intel(R) Core(TM) i5-3230M CPU @ 2.60GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 4000
GPU Driver Version                            8.15.10.2626
CPU JIT                                       [x]
Hardware Renderer                             [ ]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. https://downloadcenter.intel.com/product/80939/Graphics-Drivers
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Ah but now we got more information :slight_smile: ow the drivers are very old. From 2013, they need to be updated.

Download win64_15.33.50.5129.zip from https://downloadcenter.intel.com/download/29473/Intel-Graphics-Driver-for-Windows-15-33-?product=81499
direct link: https://downloadmirror.intel.com/29473/a08/win64_15.33.50.5129.zip

then follow this guide to install it: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/

I downloaded, and followed the instructions to the point its almost installed, a message popped saying “Update Driver Warning”


Is there any other way I could fix the crash problem without having to update my driver? Because this is a risky take :eyes:… It doesn’t help that Windows has stopped supporting Windows 7…

Uhm, why are you doing this on the GT 620M? I linked you drivers for Intel HD 4000.
Also I didn’t even know you had one because you never mentioned it nor did Citra detect it.

For GT 620M, download and install these drivers: https://www.nvidia.com/download/driverResults.aspx/132844/en-us
Then open Nvidia Control Panel and go to Manage 3D settings and set preferred GPU to Nvidia. While you are there also set Power management mode to Prefer maximum performance.

Ah, that’s why. So sorry about that… I didn’t even realized I had the GT 620M driver. On the other hand, I manage to update the other driver.


Again, sorry for the inconvenience–

1 Like

No problem :slight_smile: though you might want to use GT 620M instead, see the second paragraph in my previous post.

1 Like

Done with the update, and options. What’s next?

Actually, the game is running! Thank you so much, though I’m getting a solid 1-2 fps…

Start Citra, enable Hardware Renderer and try start a game and see if it works. You can upload a new log so we can see the settings & what GPU Citra is using.

It’s working just fine now, Thank you so much for helping me!
citra_log.txt (34.6 KB)

System Information for Support

Client Version                                Canary 1755 HEAD-41dc0b7
Operating System                              Windows 7 SP 1 (6.1)
CPU                                                  Intel(R) Core(TM) i5-3230M CPU @ 2.60GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce GT 620M/PCIe/SSE2
GPU Driver Version                            391.35
CPU JIT                                       [x]
Hardware Renderer                             [ ]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from NVIDIA’s website. https://www.nvidia.com/Download/index.aspx
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

You should enable Accurate Multiplication too so you won’t get the Disk Shader Cache bug. Ignore the bot saying your GPU is outdated, it’s a bit dumb with older GPUs :stuck_out_tongue:

1 Like

I enabled it, again, thank you so much for helping out! :smiley:

1 Like

Well although I do not suffer from the problem and I never miss, Thanks for the information,I know if the Citra crashes the first thing I should check are the Drives of my graphics card, luckily I already have them updated to the newest version that I found XD,Goodbye :grinning: