Citra crash opening Pokemon X

Everytime I try to open Pokemon X Citra just closes. Yesterday was fine but today is impossible. Even tried to delete the shaders as Ive seen some sugesting but did nothing and reinstalling too. It was my first time using citra so I dont really know if I did something i shouldnt have.

System Information

  • Operating System: Windows 10
  • CPU: AMD Ryzen 5 3600 6-Core Processor 6 Cores
  • GPU: AMD Radeon RX 6600 XT
  • Citra Version (found in title bar): Citra Nightly 1868
  • Game: Pokemon X
  • Screenshot of Issue (include the full Citra window including titlebar): -

Diagnostic Log
citra_log.txt (4.0 KB)
citra_log.txt.old.txt (10.4 KB)

1 Like

The latest Citra Nightly (1867/1868) appears to have a crashing issue with loading save states, as well as with crashing with certain titles. Please use a previous Nightly build (1866) for now:

Download citra-windows-mingw-20230326-9ef4204.7z from Release nightly-1866 · citra-emu/citra-nightly · GitHub Extract it using winrar or 7zip. Then launch citra-qt(.exe) found inside of the extracted folder.

I have the same problem with my Fire Emblem Awekening (Europe), was working perfectly yesterday, but now even in this older version that you sent it is not working. Anything else i can do to fix it?

Hey so this morning I tried to play pokemon x on the 1867 nightly build and it worked fine. As soon as 1868 released a few hours later and I installed it, it stopped working. I checked this thread and saw that 1866 might work so I tried that. It didn’t work. I then though if 1867 worked for me before I’d just try that again, and it didn’t… Would a canary build work better or is there something I’m missing here?

Quick edit
I tried 1865 and 1864 as well to no avail, also tried canary and had no luck. What could possibly be going wrong if 1867 worked before and according to this thread, 1866 is supposed to work but doesn’t for me???

Please upload a log file using Nightly 1866: How to Upload the Log File

citra_log.txt (25.5 KB)
It crashes nearly immediately after trying to launch the game. On rare occasions it will freeze on the startup screen (“loading pokemon x”) and windows will tell me it stopped responding. Either way I can’t seem to find a solution by myself so thank you for helping.

1 Like

It’s exactly the same case with me, I tried the same versions and none of them worked, the program just closed without any warning, and this is only happening with my Fire Emblem. I don’t know if it was a problem I caused, but here is my log file with 1866 in case you need it.

citra_log.txt (13.2 KB)

Thanks for your help!

Edit: I disabled the disk cache and the game started working again, but I don’t know if this can cause any problems with it!

1 Like

Please try without the use of mods.

1 Like

I have. Sorry for not saying so earlier. The initial instance of the emulator working yesterday was on 1867 WITH mods

here is a log of the exact same thing happening (I think) without any mods or anything
citra_log.txt (21.4 KB)

Hmmm, let’s try clearing the shader cache. Go to File>Open Citra Folder, then delete the shaders folder found here. Now try your game again.

1 Like

This worked. I’m playing through the intro of the game very cautiously now lol. I will message back here if something gamebreaking occurs… so far only major framedrops throughout the intro cutscenes which is definitely manageable, I’ll take what I can get. If you could, could you please help me understand how and why deleting that folder made this work? As that is not something I would’ve figured to do in a million years myself. Thank you very much for your help.

Citra generates shaders as it runs a game, which it then saves to your storage so that the next time Citra encounters that same shader in the game, it won’t need to generate it again. Rather, it can just use the shader it generated previously and saved to your storage. This reduces what emulators call “shader stutter” when you encounter new effects over time.

However, sometimes those shaders can become corrupted, either through driver/system updates, storage failures, bit-flips, or, in like in this case, a bad change to the shader cache code. It happened in one of the newer Citra versions most likely (which have a couple of issues currently), and when you used older Citra versions, you were still using the same shader cache as with the newer builds. So loading those faulty shaders made you crash immediately.


This is ridiculously well said. I understand now, thank you again.

1 Like

By the way, these issues should be fixed in the latest Citra Canary build. We will merge the change into Nightly if no further issues are discovered.

I am also unable to launch any games without them crashing. I have tried many different settings and builds. Please help.

(nightly 1866)
citra_log.txt (4 KB)

BTW, the game runs fine at 2 fps with “enable hardware renderer” disabled, but as soon as it is enabled, its runs normally for half a second, then crashes.

Please update to the latest Nightly build. This issues should have been resolved.

citra_log.txt (5.1 KB)
Tried that yesterday. Same thing.

The log file is incomplete. Make sure you follow the steps carefully:

  1. Open Citra, then go to File>Open Citra Folder (Citra>Open Citra Folder if on MacOS) and open up the log folder. Now keep that open in the background.
  2. Launch your game and encounter the problem; crash/slowdown/glitch and close Citra if it doesn’t do so by itself. Do not restart Citra as that will wipe the log of important information!
  3. Now upload the log file in this chat.