Citra crash pokemon X

Issue:
I’m trying to play Pokemon X using citra nightly but everytime I try to open the game citra just shuts down without any error message whatsoever. It used to work just fine and I thought it might be because I was playing a modified rom but I tried it with an unmodified one and it still just shuts down.

System Information

  • Operating System:
  • CPU:
  • GPU:
  • Citra Version (found in title bar): 1623
  • Game: Pokemon X
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

citra_log.txt (5.5 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Nightly 1623 HEAD-a576eb6
Operating System                              Windows 10 (10.0)
CPU                                           AMD Ryzen 5 2600 Six-Core Processor            
Graphics API                                  OpenGL ?
Graphics Renderer                             ?
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Hi, please try this:

  1. Open Citra then go to File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder if it is there.
  3. Emulation->Configure… then click on Graphics on the left
  4. Click on the Advanced tab and turn on Accurate Multiplication

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to load all shaders slowly from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.

I tried it out and now it works just fine. Thanks!

I’m having the same issue actually but the fix described here didn’t change anything for me. It turns out it extends to ALL games, even ones that previously worked fine. There are a few variables that changed from when Citra used to work and now. One obviously being the emulator updating to newer versions. Another is me upgrading my video card from a GTX 1050 to a GTX 1060. The third is me upgrading from Linux Mint 19 to Mint 20. I did make sure to have the recommended drivers for my card. Citra version is 1851.

My log is here if this helps.

citra_log.txt (14.1 KB)

System Information for Support

Client Version                                Canary 1851 HEAD-e44a132f6
Operating System                              Linux 5.4.0-47-generic
CPU                                           Intel(R) Core(TM) i7-7700 CPU @ 3.60GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce GTX 1060 3GB/PCIe/SSE2
GPU Driver Version                            440.100
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Usere have been having issues with the flatpack install. If you’ve indeed installed citra like that, you should try downloading a manual version of citra and compiling it yourself.

Is that hard to do? I have really bad luck with compiling from source. I was thankful for the flatpak because of this and it worked perfectly at first

No idea, never used linux myself. But that is how the problem is fixed according to numerous linux users.
This guide explain how to do it…I think? https://citra-emu.org/wiki/building-for-linux/

Tried following that and just got a whole bunch of errors. I guess I just can’t use Citra then :confused:

I don’t understand why the default option that the website pushes you towards is one that doesn’t even work based on what you said? Like if you click download, the only option it gives me is the flatpack info, but you’re telling me the flatpack version doesn’t work? And why did it only now stop working when it worked fine initially? A lot of things seem weird about all this…

Something recently broke the flatpack. Could be one of the dependensies or could be something on citra’s end. Since this hasn’t been a universal problem among all linux users (god knows there are a lot of linux versions), looking into it is difficult. Since users have reported that manually compiling works, I’ve simply been recommending linux users with this issue to do so. I don’t personally use linux so I sadly can’t help with compiling issues. I’d probably do more harm than good.
This version compiled apparently worked for at least one user that I know of: https://github.com/citra-emu/citra-nightly/releases/tag/nightly-1623

Unfortunately, the Linux build instructions don’t correlate to a specific version like that. You can’t use any of the instructions listed on a manual download since the files are entirely different than anything in the instructions. The instructions seem to require you cloning from the git which at least gets me the same directory structure but the actual attempt to build just fails and gives errors. Looks like I’ll just have to give up unless they fix the broken flatpack.

Try the linked Nightly above first, extract it and navigate to the folder with the terminal. You should be able to start it by typing ./citra-qt . If not you might need to chmod +x it first and/or install missing dependencies.

1 Like

oh hey, that worked! thanks!

1 Like