Citra crash while playing various games

Issue:
Citra likes to crash on various files such as pokemon y, fire emblem echoes, and fire emblem awakening. would like to ask for help. i only put fire emblem awakening in system information as the log was created when i play it. it also starts lagging when cutscenes are playing

System Information

  • Operating System: Windows 10
  • CPU: Intel® Core™ i5-7200U CPU @2.50GHz 2.71GHz
  • GPU: Intel® HD Graphics 620
  • Citra Version (found in title bar): Citra Nightly 1554
  • Game: Fire Emblem Awakening
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (169.4 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Nightly 1554 HEAD-7625306
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 620
GPU Driver Version                            21.20.16.4550
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

GPU Driver Version: Build 21.20.16.4550

This driver is outdated, you need to update.

Download win64_25.20.100.6373.zip from https://downloadcenter.intel.com/download/28289/Intel-Graphics-Driver-for-Windows-10
direct link: https://downloadmirror.intel.com/28289/a08/win64_25.20.100.6373.zip

then follow this guide to install it: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/

After you have installed that download and install igfx_win10_100.8280.exe from: https://downloadcenter.intel.com/download/29616/Intel-Graphics-Windows-10-DCH-Drivers?product=95443
direct link: https://downloadmirror.intel.com/29616/a08/igfx_win10_100.8280.exe

1 Like

got better than before but still crash after around 2 hours.

citra_log.txt (265.8 KB)

System Information for Support

Client Version                                Nightly 1554 HEAD-7625306
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 620
GPU Driver Version                            27.20.100.8280
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Turn off texture dumping :stuck_out_tongue: And delete the dump folder, you most likely have thousands of images there now (Open Citra then File -> Open Citra Folder to reach it). You might have to reset the shader cache too just in case, delete the shaders\opengl folder.

1 Like

thank you so much! :grin:

1 Like

Today Citra app just stop working i dont know why because yesterday it is still fine

citra_log.txt (20.6 KB)

System Information for Support

Client Version                                Nightly 1554 HEAD-7625306
Operating System                              Windows 10 (10.0)
CPU                                                  Intel(R) Core(TM) i7-3517U CPU @ 1.90GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 4000
GPU Driver Version                            10.18.10.4358
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [ ]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. https://downloadcenter.intel.com/product/80939/Graphics-Drivers
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

GPU Driver Version: Build 10.18.10.4358

This driver is outdated, you need to update.

Download win64_15.33.50.5129.zip from https://downloadcenter.intel.com/download/29473/Intel-Graphics-Driver-for-Windows-15-33-?product=65714
direct link: https://downloadmirror.intel.com/29473/a08/win64_15.33.50.5129.zip

then follow this guide to install it: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/

Also do this:

  1. Open Citra then go to File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder if it’s there
  3. Emulation->Configure... then click on Graphics on the left
  4. Turn on Disk Shader Cache
  5. Click on the Advanced tab and turn on Accurate Multiplication

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to slowly load all shaders from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.

Let me know if that helps, if not there might be “that” problem with the driver bug so you need to use an older build. I will link to it later, try the above first.

i am still experiencing crash, although it is less often.
citra_log.txt (4.4 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

It looks like you accidentally reopened Citra before uploading the log. The log gets cleared every time you open Citra. Have the log folder open in the background first, then start the game and when Citra closes, immediately upload a new log here

here it is.
citra_log.txt (566.5 KB)

System Information for Support

Client Version                                Nightly 1554 HEAD-7625306
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 620
GPU Driver Version                            27.20.100.8280
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Hm, settings look fine. Though CPU clock isn’t logged so you will have to tell me if it’s set to 100% (found in the System tab). Games can freeze up if it’s changed.

If you have the time, consider build Citra from source using this tutorial: https://github.com/citra-emu/citra/wiki/Building-for-Windows

One of the screenshots are outdated but it’s simply changing Visual Studio 15 2017 Win64 to Visual Studio 16 2019 Win64 instead.

Then click on image after you have finished the tutorial to start Citra through Visual Studio which will allow it to catch the crash and tell us where it crashes.

Thanks for helping out! :slight_smile:

ah, i put it as 125%. maybe that is why i experienced crash?

To be clear, I didn’t mean frame limit.

image

But if you have 125% there too definitely try change it back to 100%.

so should i uninstall the citra now before i build the citra from source?

No you don’t have to do that. Just keep as is.