Citra crashed after a cutscene middle game

Game : Dai Gyakuten Saiban 2. The game is composed of 5 episodes. Issue : the game stop working at the begining of the 3rd episode, right after the first cutscene the stories jumps directly at the end of the episode as if it was already over. It doesn’t goes to the 4th episode though, it just crashes and stays like it

System Information

  • Operating System: Windows 10
  • CPU: i7-4710MQ 2.50 GHz
  • GPU: NVIDIA GTX970M
  • Citra Version (found in title bar): Citra Nightly 1629
  • Game: Dai Gyakuten Saiban 2, The Great Ace Attorney 2
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (15.8 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Nightly 1629 HEAD-1bb2057
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i7-4710MQ CPU @ 2.50GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce GTX 970M/PCIe/SSE2
GPU Driver Version                            382.05
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from NVIDIA’s website. https://www.nvidia.com/Download/index.aspx
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Make sure to not use save states when testing, they’re not always stable.

Furthermore, update your GPU drivers.

Lastly, try this:

  1. Open Citra then go to File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder if it is there.
  3. Emulation->Configure… then click on Graphics on the left
  4. Click on the Advanced tab and turn on Accurate Multiplication

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to load all shaders slowly from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.

Yes usually i don’t use save this way but i tried everything.
I already updated my GPU drivers and it still doesn’t work.

I will try what you told me thanks !

Still doesn’t work :frowning:

Please upload another log.

citra_log.txt (42.0 KB)

System Information for Support

Client Version                                Nightly 1629 HEAD-1bb2057
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i7-4710MQ CPU @ 2.50GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce GTX 970M/PCIe/SSE2
GPU Driver Version                            456.71
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

citra_log.txt (16.4 KB)

There it is

System Information for Support

Client Version                                Nightly 1629 HEAD-1bb2057
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i7-4710MQ CPU @ 2.50GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce GTX 970M/PCIe/SSE2
GPU Driver Version                            456.71
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

I don’t know what’s causing the crash. You can try to see if you can get past the cutscene by diactivating Hardware Shaders in emulation>configuration>graphics>advanced tab. The game will run very slowly but hopefully you can turn it back on again afterwards without crashing if this works.

The only other thing I can think of is redumping the game:
Dumping Game Cartridges
Dumping Installed Titles

Update since i just learned something new. When first playing the game, I installed the translation patch, said patch is the issue : it was conflicting with the game itself because the 3rd episode (the one not working) has actually not been translated yet.
It seems the mistake was mine. Thank you for your help, it was and will be useful now that I understand better how citra works !

1 Like