Citra crashes on game load

Using Nightly 1628 (also happens with Canary 1864). Whenever I try to load a game (any game) I get the following error (launching Citra from console):

Gtk-Message: 16:11:27.606: Failed to load module "canberra-gtk-module"
Qt: Session management error: None of the authentication protocols specified are supported
/usr/include/c++/9.2.0/optional:438: constexpr _Tp& std::_Optional_base_impl<_Tp, _Dp>::_M_get() [with _Tp = OpenGL::ShaderDecompiler::ProgramResult; _Dp = std::_Optional_base<OpenGL::ShaderDecompiler::ProgramResult, false, false>]: Assertion 'this->_M_is_engaged()' failed.

Iā€™m using Manjaro Linux and here goes my system info, in case it helps:

inxi -Fx

System:    Host: perezoso Kernel: 5.9.3-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 Desktop: Cinnamon 4.6.7 
           Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: Micro-Star model: B450M MORTAR TITANIUM (MS-7B89) v: 2.0 serial: <superuser/root required> 
           UEFI: American Megatrends v: A.D0 date: 06/12/2020 
CPU:       Info: 6-Core model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2 L2 cache: 3072 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 86435 
           Speed: 2382 MHz min/max: 2200/3600 MHz boost: enabled Core speeds (MHz): 1: 2145 2: 2134 3: 2777 4: 4048 5: 3473 
           6: 4175 7: 2731 8: 4149 9: 2185 10: 2197 11: 3557 12: 3952 
Graphics:  Device-1: NVIDIA GM107GL [Quadro K2200] driver: nvidia v: 455.38 bus ID: 26:00.0 
           Display: x11 server: X.Org 1.20.9 driver: nvidia resolution: 1920x1080~60Hz 
           OpenGL: renderer: Quadro K2200/PCIe/SSE2 v: 4.6.0 NVIDIA 455.38 direct render: Yes 
Audio:     Device-1: NVIDIA GM107 High Definition Audio [GeForce 940MX] driver: snd_hda_intel v: kernel bus ID: 26:00.1 
           Device-2: Advanced Micro Devices [AMD] Starship/Matisse HD Audio vendor: Micro-Star MSI driver: snd_hda_intel 
           v: kernel bus ID: 28:00.4 
           Device-3: Trust Widescreen 3MP Webcam type: USB driver: snd-usb-audio,uvcvideo bus ID: 3-3:2 
           Sound Server: ALSA v: k5.9.3-1-MANJARO 
Network:   Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus ID: 21:00.0 
           IF: wlo1 state: up mac: 6c:6a:77:e1:15:4a 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI driver: r8169 v: kernel 
           port: f000 bus ID: 22:00.0 
           IF: enp34s0 state: down mac: 00:d8:61:4e:b6:3b 
Drives:    Local Storage: total: 698.65 GiB used: 622.46 GiB (89.1%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO Plus 250GB size: 232.89 GiB 
           ID-2: /dev/sda vendor: Hitachi model: HDP725050GLA360 size: 465.76 GiB 
Partition: ID-1: / size: 227.94 GiB used: 183.20 GiB (80.4%) fs: ext4 dev: /dev/nvme0n1p2 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 39.0 C mobo: 40.0 C gpu: nvidia temp: 49 C 
           Fan Speeds (RPM): fan-1: 0 fan-2: 932 fan-3: 0 fan-4: 0 fan-5: 0 gpu: nvidia fan: 42% 
Info:      Processes: 353 Uptime: 49m Memory: 31.37 GiB used: 3.81 GiB (12.2%) Init: systemd Compilers: gcc: 10.2.0 
           clang: 10.0.1 Packages: 1651 Shell: Bash v: 5.0.18 inxi: 3.1.08

Thanks.

Are you using the flatpak builds? Try a standalone build: https://github.com/citra-emu/citra-nightly/releases & https://github.com/citra-emu/citra-canary/releases

Yes! It worked. Thanks!

1 Like

I see. Yeah there is some issue with the flatpak builds atm.