Citra crashes on Linux when opening the rom

Issue:
As soon as you try to open the game, the program just crashes. This happens only when I have activated the option “Enable hardware shader”, and I think it might be something related to OpenGL drivers

System Information

  • Operating System: Ubuntu 20.04 LTS
  • CPU: Intel® Core™ i7-6700HQ CPU @ 2.60GHz
  • GPU: GeForce GTX 950M
  • Citra Version: Citra Nightly 1618
  • Game: The Legend of Zelda: Majora’s Mask

Diagnostic Log
citra_log.txt (16.0 KB)

In addition, when I run the program from flatpak in the terminal, when it breaks it returns the following on-screen message:

/usr/include/c++/9.2.0/optional:438: constexpr _Tp& std::_Optional_base_impl<_Tp, _Dp>::_M_get() [with _Tp = OpenGL::ShaderDecompiler::ProgramResult; _Dp = std::_Optional_base<OpenGL::ShaderDecompiler::ProgramResult, false, false>]: Assertion ‘this->_M_is_engaged()’ failed.

System Information for Support

Client Version                                Nightly 1618 HEAD-316a64961
Operating System                              Linux 5.4.0-45-generic
CPU                                           Intel(R) Core(TM) i7-6700HQ CPU @ 2.60GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce GTX 950M/PCIe/SSE2
GPU Driver Version                            440.100
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

I had to hunt around for a solution to this, it was really, really annoying. I found this thread which said that the Flatpak release does not work, but the GitHub releases do. At the time of writing, a build was released yesterday - Citra Nighty 1619. This, indeed, does work. CitraBot recommended enabling Accurate Multiplication (Configure -> Graphics -> Advanced), and while I usually leave this on, my ROMs still work without it on the GitHub release.

As far as I know, using these releases means you’ll have to update each version of Citra yourself instead of having your package manager do that for you. That might be kind of annoying but for now it seems like the Flatpak is broken (but when have Flatpaks ever worked for anything, anyway? :stuck_out_tongue_winking_eye:). Hoping this gets sorted soon as it’s easily the most convenient way to install Citra.

This crash seems to be Linux specific, but not distro specific or hardware specific. You’re using an Nvidia GPU with what I assume is using the proprietary NVIDIA driver, and you’re on Ubuntu 20.04. I’m using Arch Linux with an AMD 5700XT and Mesa 20.1.7. It also isn’t game specific, as you’re trying to run “Majora’s Mask” and I was trying to run “Animal Crossing: New Leaf”.

Fingers crossed this works for you, but it seems to be working for others (myself included) so I have high hopes!