Citra crashes when loading certain games with zink installed

Issue:
As of now,i have three games loaded:
Majoras mask (MM)
A Link between worlds (ALBW)
A Link to the past (ALTTP)
Previously, ALBW worked, but the performance was not optimal as there were stutters, speed drops and frame drops. After some research I found out that it could be do to my processor, AMD, and that to sort it I should install something called Zink. After following all the instructions in the video, I tried loading ALBW but it always crashed after a few seconds of loading, the same thing with ALTTP. However, MM worked fine which confused me, then I found out that MM runs at 30fps whereas the other two run at 60.This was the only difference I could find with the games. When I remove the files from Zink the problem fixes and the game is playable, but with poor performance. Any help?

System Information

  • Operating System: Windows 10
  • CPU: AMD Radeon™ Graphics
  • GPU: Radeon RX 5500M
  • Citra Version (found in title bar): Citra Nightly 1773
  • Game: A Link Between Worlds
  • Screenshot of Issue (include the full Citra window including titlebar):

    This is where it crashes,you can see the speed and fps drop before ultimately crashing

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt.old.txt (12.6 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                               Nightly 1773   HEAD-353aaaf
Operating System                             Windows 10 (10.0)
CPU                                          AMD Ryzen 5 5600H with Radeon Graphics          | AVX2 | FMA
Graphics API                                 OpenGL 4.2
Graphics Renderer                            D3D12 (Radeon RX 5500M)
GPU Driver Version                           Mesa 22.1.4
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [ ]

I did not find anything wrong in your log file. Please wait for a human moderator to assist.