Citra crashes when starting MHXX Rom

Citra Nightly’s latest build crashes every time I try to start the MHXX Decrypted Rom. I’ve tried disabling “Enable Hardware Rendering” and the game doesn’t crash, however it runs at 1-2FPS 5% out of 100% speed limiter

System Information
Windows 8.1 Pro:

  • CPU: Intel Core i5-3320M CPU @2.60GHz
  • GPU: Intel HD 4000
  • Citra Version (found in title bar): Citra Nightly 1629
  • Game: Monster Hunter XX
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (11.1 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Nightly 1629 HEAD-1bb2057
Operating System                              Windows 8.1 (6.3)
CPU                                                  Intel(R) Core(TM) i5-3320M CPU @ 2.60GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 4000
GPU Driver Version                            10.18.10.4425
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. https://downloadcenter.intel.com/product/80939/Graphics-Drivers
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Your drivers are out of date though I don’t think you can update them to the latest without updating to windows 10.

You have a problematic GPU for citra, please try turning off New 3DS Mode in emulation>configuration>system. If that doesn’t work, please try this version https://github.com/citra-emu/citra-nightly/releases/tag/nightly-1392 instead.
Download the version for your OS, then extract it using winrar or 7zip and run the citra-qt.exe inside the extracted folder.

1 Like

Exactly! My PC doesn’t allow me to update the drivers any more, due to me running 8.1; however, thank you so much! Disabling New 3DS mode didn’t do it, but this older build of nightly did the trick. It’s working now. Will I be able to play multiplayer on this version as well? Thanks again for your help, sir!

You should be able to use the multiplayer rooms even on an older citra version.

You can install drivers manually by following below:

Download win64_15.33.51.5146.zip from https://downloadcenter.intel.com/download/29802/Intel-Graphics-Driver-for-Windows-15-33-?product=64896
direct link: https://downloadmirror.intel.com/29802/a08/win64_15.33.51.5146.zip

then follow this guide to install it: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/

1 Like

I’ve followed these steps and successfully updated to the driver in the link, yet the latest version of Citra still crashes when loading the rom.

Yea, updating the drivers wasn’t gonna make the latest citra versions more compatible, however, the updated drivers should provide you with better performance in the older citra version.

Now that I think about it, I should’ve realised your drivers could be updated normally. Had another iGPU on my mind, apologies, Good thing tywald doesn’t have his head up his ass like I do sometimes xD

1 Like

ahh okay, good to know it will help with the performance. Much appreciated, fellas. Thank you guys for helping me out.

One last question: I’m experiencing graphical glitches, flickering. Is there any way to fix that? Or is it because I’m limited to older Citra builds?

Try this:

  1. Open Citra then go to File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder if it is there.
  3. Emulation->Configure… then click on Graphics on the left
  4. Click on the Advanced tab and turn on Accurate Multiplication

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to load all shaders slowly from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.

I’m still getting those flickers…

That is because Intel HD 4000 has driver bugs, I have them too with i7-3770K (but I normally use a GTX 1070 where there are no such issues).

Your laptop is very old, you are due for an upgrade imo :stuck_out_tongue: