Citra crashing constantly everytime i open a game

Issue:
Enter a description of your issue here, in full detail.
I first got citra today and started playing pokemon sun and moon on it. I quit citra then came back to see if i could load up my saved state. I opened citra which was no problem but when i opened the game, citra crashes and i kept trying to open it but it keeps crashing. I saw a suggestion where u have to go to files and delete opengl in shaders and that worked but i realised that u have to delete that folder “opengl” everytime u want to open the game. Its constantly annoying and i want a permanent solution. Im on a mac btw idk how to do sysytem information below pls help me ASAP. Also everytime citra closes and i opne it back up it comes up with citra quit unexpectedly.

System Information

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (4 KB)
In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

I did not find anything wrong in your log file. Please wait for a moderator to assist.

1 Like

First off, save states aren’t very stable over different citra versions. They’re not reliable. You should be relying mostly on your in-game save system to save your game. You’ll have less chance of losing progress.

Second, you were refering to the disk shader cache bug fix. There is currently a bug in the disk shader cache. If you don’t have accurate multiplication enabled with it, the shader cache will start to endlessly compile shaders in the cache, leading to immense ram usage, resulting in a crash. In order to fix it, you need to delete the old cache (the opengl folder) and enable accurate multiplication to ensure that the cache won’t contain these errors. The cache is stored in the opengl folder, hence why it reappears every time you start citra. therefore, if you’ve already activated accurate multiplication, there is no need to keep removing the opengl folder.

how do i activate accurate multiplication on mac

Citra>preferences I think. Go to graphics>advanced tab>accurate multiplication.

i enabled accurate multiplication but its still doing the same thing

yo sleeping snake pls reply

Provide new log… For support

Your previous log was incomplete. Make sure you follow the steps carefully:

  1. Open citra and go to emulation>configuration>general>debug>select open citra folder. Now keep that open in the background.
  2. Launch your game and encounter the problem/crash/slowdown and close citra if it it doesn’t do so by itself. Do not restart citra as that will wipe the log of important information!
  3. Now upload the log file in this chat.
    Hopefully that will give us some more information to work with.

i don’t have the configuration option when i got to emulation

citra_log.txt (5.0 KB)

System Information for Support

Client Version                                Nightly 1623 HEAD-a576eb6
Operating System                              macOS 10.15
CPU                                                   Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz
Graphics API                                  OpenGL ?
Graphics Renderer                             ?
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

help pls @SleepingSnake

Does disabling Hardware Shaders allow you to launch your game?

omg yes it does. I disabled Hardware Shaders and now it opens every time i click the game without having to delete the shaders folder ty.

Hey late and random but this issue has been bugging me all day, and disabling Hardware fixed it right away, thank you so much for your help in this threads, its a big help.

Please help me I can’t open my games
citra_log.txt (25.4 KB)

System Information for Support

Client Version                               Nightly 1724   HEAD-19617f7
Operating System                             Windows 10 (10.0)
CPU                                          AMD Ryzen 3 2200G with Radeon Vega Graphics     | AVX2 | FMA
Graphics API                                 OpenGL 3.3.0
Graphics Renderer                            AMD Radeon(TM) Vega 8 Graphics
GPU Driver Version                           22.7.1.220725
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [ ]
System Region                                -1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • Please enable the Vsync option if you are experiencing screen tearing.

Download citra canary. Citra nightlin does not work with “Adrenalin 22.7.1” drivers.

1 Like