Citra crashing in festival plaza in usum

whenever I load into the festival plaza in ultra sun it runs fine for a few minutes then freezes, this happens in both canary and nightly, it also has issues when trying to restart the emulator from the emulation option, it crashes instead

System Information

  • Operating System: windows 10

  • CPU: radeon fx 8350 eight core processor

  • GPU: radeon rx 580 series

  • Citra Version (found in title bar): citra canary 2135

  • Game: Pokemon Ultra sun
    citra_log.txt.old.txt (798.4 KB)

  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:

System Information for Support

Client Version                               Canary 2135   HEAD-57891c0
Operating System                             Windows 10 (10.0)
CPU                                          AMD FX(tm)-8350 Eight-Core Processor            | AVX | FMA
Graphics API                                 OpenGL 3.3.1
Graphics Renderer                            Radeon RX 580 Series
GPU Driver Version                           22.4.2 30.0.15021.7000
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [x]
Shader JIT                                   [x]
System Region                                -1
Shader Disk Cache                            [x]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • Please enable the Vsync option if you are experiencing screen tearing.
  • The CPU Clock percentage is not 100%. You may experience unexpected game speed.

is there a way to run it on a different render method? or is there a way to make it work with openGL correctly? I was going to try uninstalling and reinstalling citra but from the sounds of it that wont work

Go to Emulation > Configure > System and set the CPU Clock Speed back to 100%. You should not mess with this setting if you don’t know what you are doing. Then retry your game.