Citra crashing when trying to access saves and play coins

Issue:
Enter a description of your issue here, in full detail.
I’ve been playing Persona Q, and it was going just fine until a little while ago, when it started to have a fatal error whenever I tried to save in game or whenever the game tried to check the play coins. It seems like things that would be related to the internal system, but I can’t think of anything to fix it.
System Information

  • Operating System: Windows 10
  • CPU:
  • GPU:
  • Citra Version (found in title bar): Nightly 1659
  • Game: Persona Q: Shadow of the Labyrinth
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (53.2 KB)

System Information for Support

Client Version                                Nightly 1659 HEAD-3f13e1c
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Celeron(R) N4100 CPU @ 1.10GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) UHD Graphics 600
GPU Driver Version                            23.20.16.4973
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Looking at the log and the related code (core\file_sys\archive_extsavedata.cpp, core\file_sys\savedata_archive.h) I believe there’s an oversight on how SaveDataArchive is serialized (it probably shouldn’t be) and so savestates break saving if you changed the user folder path.
What I think happened is that you had a save state you made previously, then you changed the path to citra’s user folder somehow (moved the folder, or maybe it’s on a USB stick and it’s no longer F:) so it broke anything that needs access to the emulated filesys.

So my only solution for you would be to find a way to get citra to be on F:\Citra\nightly-mingw again and save conventionally there (and then you can move back, conventional saves are not affected by this issue).

Thanks for the response, and you were right about it being on a USB and the user folder being moved, so now I think I know how to fix the issue. Thanks a bunch.