Citra crashing with controller

it crashes everytime i adjust the coords on my controller. everytime i try to adjust my controller it freezes then crashes. it must be the new update i just installed because it was working perfectly fine last night

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

citra_log.txt (3.7 KB)

System Information for Support

OpenGL Vendor                                 null
OpenGL Renderer                               null
OpenGL Version                                null
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

I did not find anything wrong in your log file. Please wait for a moderator to assist.

What is the name of your controller? Try show with a couple of photos for the front and back of it.

If it worked before, try bisect the issue by testing builds from here:

Input <Error> input_common/sdl/sdl_impl.cpp:InitJoystick:199: failed to open joystick 0
Haven’t seen this error before.

its a simple powera switch controller ive been using ever since i got back into pokemon roms image

i figured it out. its something to do with the most recent update that caused the crashing. using the one previous to the newest one and its working again. thanks for the help :slight_smile:

To clarify, Nightly-1431 doesn’t work but Nightly 1430 does?

it appears so. used 1430 and it worked perfectly

1 Like

It wasn’t in the log as the log was cut off, but what is your OS? Ok so it’s 99% of chance that you’re on Windows (the change was only on the windows build system, I had forgotten).
I am the dev responsible for the change, so I may ask you to test further into the future, is that ok with you?

sure. (forced to make this 20 chars)

So I have a few versions I need someone to try.
this one (mingw) and this one (msvc) are versions that should still have the problem, but print the error from SDL into the log. Please upload a log generated from them here if you can. (If one works but the other doesn’t, upload the log from the one that doesn’t work, with an indication of what version it is from)

While this one (mingw) and this one (msvc) are a version that’s supposed to fix the problem. Please report if the problem is fixed by the change.
The versions are based on my current auto binding PR, but you can ignore that part.
(Split the post because the forum won’t allow me to post more than 2 links)

You can now try it using the latest Canary (1591). Please report if the problem is fixed by the change.