Citra Crashing with trying to Launch Pokemon X on M1 MBA

Issue:
Enter a description of your issue here, in full detail.

I got Citra running on Native M1 (on my Macbook Air) from a GitHub page, I tried loading a Pokemon X ROM but right after I selected the language, the app crashed and gives me an error every time I try to load the ROM again. Have tried removing and adding it again as well, and turned of Hardware Acceleration as well.

System Information

here’s the system log:
citra_log.txt (5.2 KB)

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

No game was booted in your log. If you are experiencing a crash then do not open citra again until after you posted the log as it gets purged when you reopen citra.
For more information, see How to Upload the Log File

M1 MacOS devices are currently unsupported. Its possible to get them to run through Rosetta 2, but there are many game-breaking bugs, glitches and other inaccuracies that we cannot provide support for. Sorry for the inconvenience.

but there any many tutorials on YouTube that say using this ported version, everything works fine.

Good for them. Its not true.