Citra deletes it's own save files after every reset

On commit: b124e50 Bleeding Edge, same happens on regular compiled build.
Specs: Core i3-6100, GTX 750 Ti, 6 GB RAM, Windows 10 Pro 64-bit.

Citra just flushes it’s own save data of every game it launches. I was testing out a bugfix for one game, when I needed to reset the save data for myself to see if the bug is fixed. I just copied over all the save files for the games to the desktop, I even checked the sizes of everything. I deleted all the files in the save directory and tried to see, if the bug is fixed. Once I checked that, I copied over all of the save data again. And then, this thing happens. What is the cause of this?

i think you are missing a picture that your forgot to include

You mean the log file? Here you go: https://1drv.ms/t/s!AoHubDOu-cNohhEIcJ-xLS7iD9ZL

that is what i am not understanding, sorry if it is flying over my head but what happened?

I was just checking issue #2110 on a nightly build, because the other game had the same bug (zero input width), but it didn’t crash? Then I copied all of the saves from my desktop to where it belongs. When I copied them over, I tried to load the game, but everything was overwritten.

Where did you copy them to? You need to be more clear and give us steps. Also provide logs.
Did you follow this guide? https://citra-emu.org/entry/migrate-your-savefiles

  1. For the testing, the directory had to be empty, because I needed to start a new game. So, I copied them from AppData\Roaming\Citra\sdmc\Nintendo 3DS\00000000000000000000000000000000\00000000000000000000000000000000\title to desktop.
  2. When the testing was complete, I needed to put the files back, where they belong (in the 1st step)
  3. This thing happens - Whenever I load a saved game, it will overwrite the save file with a 0 kb file.

I tried to also follow the guide, but there’s no user folder in my Bleeding Edge folder (0.1.170)

You don’t need to follow the guide, your save data is already located in the correct location.

Did you make sure to move the entire folder for the game? Did you make sure to close Citra before moving the files back to the correct location?

I’ve never encountered anything like that, and I am constantly moving save files and testing games.

Yes, I placed them to where I could find them easily. Yes, of course, Citra was closed. This issue is a first for me. I also was copying some files back then.

EDIT: Is this normal? [ 14.710077] Service.FS core\file_sys\archive_sdmcwriteonly.cpp:ArchiveFactory_SDMCWriteOnly:35: Directory C:\Users\Hexagon12\AppData\Roaming/Citra/sdmc/ set as SDMCWriteOnly. If it’s write-only, it actually can’t read the files, right?

Can somebody test my Pokemon Super Mystery Dungeon save file? (Before I copied that folder into that directory)
https://1drv.ms/u/s!AoHubDOu-cNohhLJR-AHZYDbZc-T

Fixed!

Just needed to copy files not to the games’ folders, but to 0040000 folder.