Citra does not recognize input from my GCN controller

Issue:
Citra does not recognize my gamecube controller (official nintendo adapter, the driver works)
I copy pasted many different controller configurations into the “qt-config.ini” to no avail.

System Information

  • Operating System: windows 10
  • My pc: Intel® Core™ i7-4720HQ CPU @ 2.60GHz (8CPUs), ~2.6GHz
  • Citra Version (found in title bar): Citra Bleeding Edge | HEAD-0ceaf22

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

Read this thread:

How does that thread relate to my issue?

Are you using the Mayflash driver?

Oh, i just noticed that, Citra Bleeding Edge has been abandoned for quite some time, use the latest citra canary or nightly build.

I’m using the Wii U USB GCN adapter driver (vjoy)
Will the mayflash driver work for the nintendo Wii-u gamecube controller adapter?
I thought Bleeding edge was the newest version

First try it on the newest citra build (either canary or nightly) your current setup and check if this issue persists.

i’m not sure about that, you will have to test it for yourself.

Ok now it works, I can finally move in-game using the gcn controller, I just need to perfect it a little lol
Using nightly version now

Remember to use the ‘Set Analog Stick’ option to configure the ‘Circle Pad’ and ‘C-Stick’.

Yeah that part is pretty straight forward, but in oot3d, whenever i try to target things link gets locked in the sidestepping mode so I have to hold the L button to be able to run around normally for some reason.

  • link can’t run, only walk slowly

Nvm, figured those out