Citra doesn't detect my controller

Issue:
So, I wanted to play some 3DS Pokémon games, and just updated my Citra Nightly Launcher, loaded up a game, and then I noticed that the emulator didn’t detect my controller, I use an wired bionik vulkan controller, and tried closing the emulator and opening the emulator and still didn’t worked

System Information
Old laptop from 2014, that surprisingly runs games at 25-30 fps minimum, sometimes reaching 40-60 fps for some games that are very compatible with the emulator

  • Operating System: Windows 7
  • CPU: Intel Core i5-3320M 2.60GHz
  • GPU: Intel HD Graphics 4000
  • Citra Version (found in title bar): Citra Nightly 1728
  • Game: Pokémon XY, and Super Mystery Dungeon
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

Citra recently updated it’s SDL version. Some config file might’ve gotten corrupted because of it unfortunately. Go to File>Open Citra Folder, then open up the config folder and delete the qt-config.ini file found here. Now restart Citra and try to map your controller again.

Another things is that you say you’re using Nightly 1728, this isn’t recommended for your GPU as that has driver bugs on the latest versions of Citra. To prevent running into any issues, you should be using this older build instead:
Download citra-windows-mingw-20191214-ddb7ead.7z from Release nightly-1392: Merge pull request #5020 from jroweboy/dynamic-mf · citra-emu/citra-nightly · GitHub
Extract it using Winrar or 7zip. Put the extracted folder anywhere you want. Now run citra-qt.exe from the folder and run your game.