Citra doesn't open and I'm going mad

Issue:
Hi, I’m trying to use citra on my laptop… and i just can’t open it.
I already read dozen of post like this, so i tried almost everything.
At first, i tried to open the citras version inside winDS pro (which i downloaded 1 year ago) but only citra 32 was working and i couldn’t play on that. So i downloaded the installer for citra, and nothing; so i downloaded the compressed file of citra, and nothing; i created the folder “user”, and nothing; i updated windonws 10, and nothing; i tried to install the intel’s driver that i found in this site, and nothing; i tried to unistall some C++ (right now i only have Intel(R) C++ red. 64, M. visual C++ red. 2013(x64) / 2015(x86) / 2015-2019(x64) ), and nothing; i tried to delet every version of citra and donwload it again, and nothing; i tried to download it on my mom’s laptop, and… it seems to work easily. Now, on that laptop i just open citra and didn’t lauch any game, because that laptop is OLD (i5 3200… yeah) but i managed to open citra.
So… What in the hell is wrong with my laptop?
I really hope some one will help. Thanks.

System Information

  • Operating System: Windows 10 20H2
  • CPU: i5 6200U
  • GPU: Radeon R5 M430
  • Citra Version: the last i guess
  • Game: //

Diagnostic Log
[ 0.115832] Frontend citra/citra.cpp:main:323: Failed to load ROM: No ROM specified

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

Since you may have created a bunch of problem whilst trying to solve the problem. Let’s try squashing all of them at once. That way we’re at least sure we’ve got a clean baseline to work with (make sure you read the instructions carefully):

Make sure you’re trying to run citra-qt.exe and not citra.exe (citra.exe doesn’t have a user interface)
If that is the case:
Press both your Windows Key + R at the same time. Then type in %localappdata%/citra and press Ok. This should open up the folder with your Citra installation. Delete everything in here.

Now press both your Windows Key + R at the same time again and type in %appdata%/citra and press Ok. Delete everything in this folder as well.


Next, let’s make sure your drivers are sorted:

For your intel iGPU:
Download win64_15.45.5174.zip (direct link) from Download Intel® Graphics Driver for Windows* [15.45]

Then follow this guide to install that driver: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/

Now download and install the latest driver: igfx_win10_100.9316.exe (direct link) from Download Intel® Graphics - Windows® 10 DCH Drivers

For your dedicated AMD GPU:
Go to https://www.amd.com/en/support/graphics/amd-radeon-r5-series/amd-radeon-r5-400-series/amd-radeon-r5-m430
Look under the Windows 10 - 64-Bit Edition tab and download the recommended driver there. Then install it once it is downloaded.


Since you said you deleted some of the visual C++ files, let’s make sure you have everything you need installed.
Open this link, then follow the instructions listed on the site: Visual C++ Redistributable Runtimes All-in-One (Mar 2021) Download | TechPowerUp


After you’ve followed all of the steps listed above, download Citra’s installer from our site: Download Citra - Citra
Once downloaded, run the installer. If you still can’t open Citra after installing, make sure you’re opening Citra using our shortcuts or by running citra-qt.exe and not citra.exe. try adding an exception to citra-qt.exe to your anti-virus software. If you don’t have a dedicated anti-virus software, then try adding an exception for citra-qt.exe to Windows Defender instead.

Let us know if you this helps resolve your issue.

1 Like

right now it’s 17:00 and i’m working… so when i come back home i’ll be able to let you now.
By the way thank you very much for your help.

PS: i know i have to run citra-qt.exe, so that’s not the problem, i guess… besides i tried to run all of them, citra.exe open the black window and then it close itself (and this should be normal) while citra-qt.exe load for 10 seconds and nothing happen, but only the first update citra_log.txt

It’s working! Yeah!
Windows defender wasn’t the problem… So it was the drivers or C++, i’m still confuse about the story of my mom’s laptop. It is very old and unused, so i don’t think drivers in my PC were the problem, so C++ were messing up (actually i never had to deal with those before).
Thank you man. And thank you for made me update drivers, because i never would!

1 Like

If by C++ you mean the Microsoft VC++ redistributables, those are like any other library installed on your system and are extremely unlikely to be the culprit.

Some systems don’t come with the correct runtimes installed. Hence why it’s a good thing to make sure that users have all the runtimes that Citra could ever need if they’re experiencing issues with initialization. It’s just a troubleshooting measure.

I didn’t mean to imply that it wasn’t a good measure to make sure they are installed. My response was to:

so C++ were messing up

Which indicates that there is some problem with them, not that they were not installed in the first place. Maybe its a language barrier issue; either way, I wanted to make it clear that its extremely unlikely that the redistributables (assuming they exist on your system at all) “messed up”.

It doesn’t matter for this particular instance, since the problem is solved; but if the poster ever encounters the problem again; it might be useful to help track down the actual cause.

True enough.

That is up to OP. I only gave them these steps in the way that I did because they seemed to have tried to fix the problem on their own. Meaning that their fixing attempts might intefere with my troubleshooting attempts. For example, It would’ve been hard to determine what would cause the the first troubleshooting instruction to fail if I were to guide them through the steps one at a time.

If they have issues in the future, we’ll deal with it then.