Citra doesn't read cheat txt files (and) doesn't create them either

Issue:
As you can imagine, I tried using cheats for Dragon Quest VIII but it seems citra doesn’t want to make them work. There’s really not much else to say.

System Information

  • Operating System: Windows 10 Home 64 bits
  • CPU: Intel® Core™ i7-5700MQ CPU @ 2.40GHz (8CPUs)
  • GPU: NVIDIA GeForce GTX 765M
  • Citra Version (found in title bar): Citra Nightly 1244
  • Game: Dragon Quest VIII: Journey of the Cursed King [USA version; Original Symphonic Music & Uncensored modifications; Decrypted game]
  • Screenshot of Issue (include the full Citra window including titlebar): there’s no screensot to make, the game just desn’t detect cheat files and doesn’t create them either. Nothingm ore, nothing less.

Diagnostic Log
Log uploaded, but I don’t know if it will be of any use.

PS.: there are some things that may be useful.
First off, I know citra doesn’t let you install it on a folder with non ASCII characters (but with winDS pro apps it gets installed anyway, and I have the winDS pro version). My user folder does have such characters and that might be the issue; but, on the other hand, SD files are saved correctly, save files are saved correctly, and i have no issues with game file paths and so on.
Maybe the issue is with this “modded” version of the game, but it shouldn’t really, because the modifications are purely aesthetic (changing textures and sound files for others). Also the game keeps its Title ID intact.
OR maybe the cheats I found don’t work (bc of EU vs USA versions, bc the cheats are trash, bc idk). Let’s say I already tried everything on this regard.

Thanks in advance.
citra_log.txt (657.5 KB)

System Information for Support

Client Version                                Nightly 1244 HEAD-e9c2b27
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce GTX 765M/PCIe/SSE2
OpenGL Version                                3.3.0
GPU Driver Version                            425.31
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             [x]
Enable Shader JIT                             [x]
System Region                                 -1

Here’s some issues I found with your log that might help.