Citra doesn't recognize controllers on Linux (XONE & generic)

I’m running Ubuntu Linux with 2 controllerscitra_log.txt (4.5 KB)
ID 045e Xbox One Controller
ID 079 DragonRise - Generic controller

Both are recognized by the system out of the box (I’m using jstest-gtk to check it). But I can’t map them on Citra, as they were not connected.

I’ve tried to follow this old tutorial.

I can change the file and Citra even shows the new parameters but it doesn’t do anything. I tried to delete the .ini file and start it all over, tried different settings, nothing happened.

So, what could I do now?

System Information

  • Operating System: Linux Ubuntu 19.04
  • Citra Version (found in title bar): master-aa04eddcb (2019-09-11)*
  • Game: Mario 3D Land (testing)

*I tested both canary and nightly packages. I’m using Ubuntu snap packages

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

System Information for Support

OpenGL Vendor                                 null
OpenGL Renderer                               null
OpenGL Version                                null
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Are you using any specific driver like xpadneo?

I believe I’m not. I haven’t installed it and my xone controller is the older one, which has no bluetooth.

I used both controllers with USB cable.

if you have steam installed disable the controller support option on steam settings.

I couldn’t find a clear option to disable controller support. I tried a few options but none made any difference. So I removed Steam, which also didn’t work.

I will try to boot alive version on an usb stick and test my controllers on another computer running windows, just to be sure.

I’m having the same problem with my 8bitdo SN30 Pro+ and I don’t see anything to disable controller support in steam either.

I’m running POP 19.10 and my controller is not recognized in either the nightly or canary builds of Citra. Any additional ideas on getting this to work? It doesn’t matter if my controller is connected via a wire or bluetooth citra just doesn’t seem to see it.

I’ve managed to make Citra recognize my controller.

The issue was in Flatpak, since it sandboxes everything including device inputs (from what I’ve heard from here). Thanks to this I just rewrote the command provided to this:

sudo flatpak override --device=all org.citra.citra-canary

And the controller was recognized soon after.

So do you have to always run Citra from terminal with sudo? Is there a non terminal solution?

I’m having exactly the same issue. I’ m running Ubuntu 18.04, latest canary and nightly build from snap store(also called Citra-mts). I suspect that Snap sandboxes devices like Flatpak does, but I don’t really know much about it. If it does, is there any way to make snap recognize controller?

5 minutes later
Lol, wait! I just found the solution, it’s very easy! First, launch Ubuntu app store, then go to the page of Citra-mts, click the Permission(P button, select enable connected joystick! My xbox one controller is now ready to go XD

1 Like

LMAOOOOOOOO thanks a lot man, It would take a couple decades to find this one