Citra doesn't reconize SD card or want to save in mhxx

Issue:
Citra is able to load my save file and i’m able to load my save game. But once i’m in game Citra refuses to save my game. It says it doesn’t detect my SD card. I’ve also tried deleting my save file in the hopes that Citra will just create a whole new file but that doesn’t work either.

Loading the save file however on my real 3DS i’m able to save just fine.

System Information

  • Operating System: Windows 10 x64
  • CPU: i7 8700k
  • GPU: 2080 rtx
  • Citra Version (found in title bar): 1420
  • Game: Monster Hunter XX
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (132.6 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Nightly 1420 HEAD-4991c01
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce RTX 2080/PCIe/SSE2
OpenGL Version                                3.3.0
GPU Driver Version                            432.00
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from NVIDIA’s website. https://www.nvidia.com/Download/index.aspx
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Try with a portable Citra, i.e extract a standalone build by doing “manual download” https://citra-emu.org/download/ then create a folder called user in there.

Then only put the save file back. If it works then perhaps you have file permission problems in your AppData.

I never had this issue myself so I don’t really know :confused:

which builds are portable? nightly and canary both run off your %appdata% as far as i’m aware.

All builds :stuck_out_tongue: you just create a user folder where citra-qt.exe is at.

Ok, i have tried this but still no dice.

Hm, can you upload your save? You probably need to link from Google Drive or something. (maybe do it in a private message so your save doesn’t get spread on the internet :stuck_out_tongue: )

Hello, could you find a solution to the problem? Exactly the same thing happens to me