Citra doesn't register controller inputs

Issue:
Citra refuses to connect or register any controller when plugged in. I’ve tried with PS4 DualShock 4 controller, and Nintendo Switch Pro Controller, Citra will not connect to or register the controller device when plugged in. If I try to go configure my Controller Input buttons and map the buttons for the controller, Citra will simply not register any input from the controller whatsoever.

Citra should have some option to configure what it should look for when it comes to driver devices, DirectInput, XInput or SDL2, the latter would work better since its a rather common library when it comes to detecting controller inputs and devices properly.

I have tried and tested with multiple versions of Citra, Nightly build from Flatpak, Citra from AUR, Citra from Github, all show the same issue of not registering the controller at all despite being connected over USB. They work perfectly fine for any other emulator that I use on my system, and they all use XInput or SDL2 with xboxdrv and joycond drivers.

System Information

  • Operating System: Manjaro x86_64
  • CPU: Intel i7-7700k
  • GPU: Asus GTX 1070
  • Citra Version: Citra Nightly 1708 // Citra Canary 1959_20210424_651c9d0-1 // Citra-git r8793.d88d22080-1
  • Game:
  • Screenshot of Issue:
    image

Diagnostic Log
citra_log.txt (10.1 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Does your device recognize the controller outside of citra?

Incase you couldn’t read, I specifically said in my post that it works with everything else except Citra.