Citra doesn't respond when launching any kind of game when discord is opened (solved)

#1

Issue:
Enter a description of your issue here, in full detail.
When I attempt to launch any game it’ll start by attempting to launch the game and give me a low speed and frames and given a few seconds it’d stop responding, give me a 0% speed value and a nan ms frame.
Edit: Found the issue which was discord, found it to be interesting, log file is in the comment if anyone is interested in looking into that.
Edit 2: It was the discord overlay which is activated on Citra . .

System Information

  • Operating System: Windows 10
  • CPU: Intel® Core™ i7-3610QM
  • GPU: Intel® HD Graphics 4000 or NVIDIA GeForce GTX 675M
  • Citra Version (found in title bar): Nightly 1774
  • Game: Any
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (14.8 KB)
In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

#2

I did not find anything wrong in your log file. Please wait for a moderator to assist.

#3

Managed to get Citra to consistently load games. Apparently, it couldn’t load anything when Discord was opened which was strange, here’s the file in case anyone is interested in it. citra_log.txt (63.1 KB)

#4

I found some issues in that log that need resolving:

  • Citra is currently utilizing open-source system files which may cause emulation to be less accurate, but not affect system stability.
#5

I did not find anything wrong in your log file. Please wait for a moderator to assist.

#6

Does it work with Discord Presence? you can find this setting on Emulation > Configure > General > Web > Show Current Game in your Discord Status. check that option and open citra again and see if it works.