Citra doesn't work in smartphone

I’m trying to play to IEGO Galaxy Supernova (which works perfectly in Citra on my PC) at my smartphone but when I start the game the screen turns black and appears a message which says “fatal error”.

My phone is a Motorola Moto g10, the citra version is the last one available at the Play Store and this is what appears in the log archive:

citra_log[2].txt (6.3 KB)

Any help is appreciated, I have already tried reinstalling citra and downloading the file again and the same thing still happens.

In order for us to provide better support, we need to see the log generated by citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File

[ 6.336813] Service.FS <Info> core/file_sys/archive_selfncch.cpp:OpenRomFS:193: Unable to read RomFS
^ Your ROM is corrupted. So your game file probably got damaged when you transferred the ROM to your phone. Try moving it over again.

I tried to moving it over again like 20 times and it still happening the same, I use a USB type C to transfer it because I can’t upload it to google drive (it always says that there is an error douring the upload), I’ve also tried other online transfer methods and in the end I find the same error but it still running on PC without any problem.

Its definitely corrupted. Is it the exact same file that you’re running on desktop? Or is it a copy of said file that you’re copying over. Make sure it’s completely consistent. Large singular files like these love to get corrupted with the slightest problem during the transfer, so try another cable if you think that may be the issue.

still no working, I used the exact same file instead of a copy and still happening.

How exactly did you do this?