Citra DQMJ3 0 fps in loading screens and freezes

Issue: well like the title says it im trying to play DQMJ3 and i get fps drops and the loading screens are so long because i get 0 fps in loading not sure why
Enter a description of your issue here, in full detail.

System Information

  • Operating System: Windows 10
  • CPU: AMD Ryzen 5 3600X
  • GPU: Nvidia GeForce RTX 2060
  • Citra Version (found in title bar): Citra Nightly 1554
  • Game: Dragon Quest Monsters Joker 3
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (19.7 KB)
In order to save a copy of the log, follow this guide:

System Information for Support

Client Version                                Nightly 1554 HEAD-7625306
Operating System                              Windows 10 (10.0)
CPU                                           AMD Ryzen 5 3600X 6-Core Processor             
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce RTX 2060/PCIe/SSE2
GPU Driver Version                            446.14
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [ ]
System Region                                 2
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Enabling accurate multiplication didnt change anything.

There is currently a regression with this game, on my end it seems underclocking to like 20-25% (drag the CPU slider in the System tab) helps a lot. The other way is to rollback to an older version before the accurate core timing changes which would be Nightly 1543:

Enable Shader JIT and keep Accurate Multiplication enabled or you will end up crashing due to a bug with Disk Shader Cache when Accurate Multiplication is turned off. Since you have had it off for awhile you should clear the cache so it can be built up corrrectly from scratch. To do that do the following:

  1. Open Citra then go to File->Open Citra Folder
  2. Delete shaders\opengl folder

Thanks im playing on 1543 Citra and its way better thanks for taking the time to help me, have a good day :smile:

1 Like

First, SORRY to revive this old thread, I actually found 3 posts with this exact similar issue… for the same games (Dragon Quests Monsters 2 and Jokers 3)


I find it very odd that any recent Nightly OR Canary version of Citra simply cannot run either of those games properly… I get 30 (or) 60fps EASILY locked 100% of the time (running on a 9600k at 5ghz, 32gb ddr4 and a 2070rtx)

The problem is always on any screen transition or loading, when using a recent citra version, it takes way longer, there is an audio glitch repeating, fps drops to 0, frame latency gets in the thousands and as soon as the loading is done, everything is back to being perfect… dropping cpu to 30% did improve the situation slightly (any lower and the game crashed), but still not to the level or speed of the citra build from 1 year ago!

I have also tried messing with shader cache, Accurate Multi and many other settings but nothing seemed to improve it either…

Anyone has any suggestion? :slight_smile:
Thanks for your time and have a nice day!

It is caused by a regression with “accurate core timing” change that got merged since Nightly 1544. You should use Nightly 1543 until this get fixed someday.

That is what I have been doing… I just find it completely crazy that this has been going on for more than a year with zero progress… there have been 500 commits/updates to Citra since then… And there is no workaround to using a recent version without having to deal with that bug?

Are they even aware of that issue? Anyone looking into it? Anything we could do to help out? :smile:

Going to Nightly 1543 did do the trick but not entirely. Same thing does happen later in the game: screen fade to black, 0 fps and audio glitches.

Is there another regression in Citra? Some people claim the game is working fine on earlier version but they do not mention if they finished the game or just played a bit.

My citra yesterday was normal, and today it is giving this freezing problem.
Operating system: Windows 10
CPU: I7 3770
GPU: Intel HD graphics.
game: pokemon Y