Citra exits itself when trying to open Decrypted ROM

#1

Issue:
I have my Pokemon SUN Decrypted ROM. I have sully installed Citra Nightly. I am running cirta-qt as admin. I have updated C++ as per the FAQ prior to install. I have redownloaded and reinstalled many times. The emulator detects my game. I double click to start the game, then it loads for 2 seconds and closes. No error. No crash. Just closes. I have tried to get something off the log file, but it remains blank, possibly because the game hasn’t actually launched. When I enter back into Citra, I have to locate my game directory again.

System Information

  • Operating System: Windows 7 Home Premium
  • CPU: Intel Core i5-3550 CPU @ 3.30Ghz
  • GPU: AMD Radeon 7700
  • Citra Version (found in title bar): Citra Nightly #789
  • Game: Pokemon SUN
  • Screenshot of Issue (include the full Citra window including titlebar): Cannot take screenshot as no error occurs. It would just be a screenshot of the desktop.

Diagnostic Log
I have tried everything and anything to get something to appear in the log but i remains blank no matter what.

#2

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

#3

Could you try latest canary:

#4

No luck. Still the same issue.
I’ve been googling and searching forums for days and haven’t seen anyone else with this issue so I can only assume it’s something on my end but I can’t think of what it could be??

#5

Are you sure you’re opening citra-qt.exe and not citra.exe? If you used the installer, the shortcut would open this.

#6

No, I’m definitely opening citra-qt.
The double click i was talking about is when I’m actually ckicking on the game.

#7

It’s hard to determine the cause of the issue without the log. Try redumping your game.

#8

Just redumped sun and dumped moon as well as a contolled test.
No success with either… this is so frustrating.

#9

this is odd, does that happen to any other app on your pc? it doesn’t look like a citra issue.
try dragging your rom file into citra.exe on citra folder.

#10

You should not be running Citra as admin, because it opens up a security hole in your system.

#11

Would this be cause of my issue? Because running normally gave the same problem. Thanks for the side note though.

#12

Could you try to record the desktop when you face this issue ?
(Start recording before you open citra & end it after the crash)
It’d clear things up.

#13

No, it wouldn’t, I just figured I would point that out because Citra is currently not very security oriented, that is, a malicious homebrew breaking out of Citra’s sandbox wouldn’t be entirely unheard of.