Citra Fails to start on ROG ally

Issue:
Citra crashes at startup on ROG ally running latest drivers. Note that ASUS is a bit behind the AMD driver releases which is my guess as to what’s going on seeing as the root failure is in an AMD driver. I’ve reinstalled the current ASUS published AMD drivers and tried a full wipe of Citra ( app/local and app/roaming removed.

System Information

  • Operating System: WIndows 11
  • CPU: AMD Ryzen Z1E
  • GPU: AMD Ryzen Z1E
  • Citra Version: latest nightly and Canary
  • Game: Did not get into game
  • Screenshot of Issue, Application crashes at launch
  • Driver Version AMD 31.0.22023.6003

Diagnostic Log (No log file is generated as Citra crashes at start)
Windows Application Logs from Event Viewer
Faulting application name: citra-qt.exe, version: 0.0.0.0, time stamp: 0x65b6f4f1
Faulting module name: amdxc64.dll, version: 31.0.22023.6003, time stamp: 0x6566aeda
Exception code: 0xc0000005
Fault offset: 0x00000000000a541f
Faulting process id: 0x0x850
Faulting application start time: 0x0x1DA53078BC88AFB
Faulting application path: C:\Users\ethan\AppData\Local\Citra\canary\citra-qt.exe
Faulting module path: C:\Windows\System32\DriverStore\FileRepository\u0398667.inf_amd64_f7fcccf565a8b59e\B398200\amdxc64.dll
Report Id: 4649fde1-a7c6-4e16-913f-4a87cff37eb3
Faulting package full name:

In order for us to provide better support, we need to see the log generated by citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File

Emptylogfiletoappeasebot.txt (11 Bytes)

Update , This apears to be related to a bad window update install. A roll back to a system restore point has corrected this issue. Intertying it did not effect all graphics calls as newer games would run but Citra and Pcsx2 booth displayed the crash behavior.

1 Like

Same issue here, and I can not even upload my log file, because Citra crash just after launching the main app not after launching game. Are there any way to generate log file without change settings in app?

1 Like

Go into windows settings. Apps. Look for something called “opengl, opencl, and vulkan compatibility pack”. if you have it uninstall it

3 Likes

I have the same issue. Tried to launch it within Retroarch : didn’t work. Then I downloaded the last version from the official website, and it crashes all the same, just after I answer the telemetry question box (no matter what answer I choose). I even tried the “Canary” version : same problem. I can’t post my log either, since the app doesn’t even start. I also tried all the power configurations (10W, 15W, etc) and settings (with or without turbo boost, etc…), but it still doesn’t work for me. And of course all of my system is up to date (BIOS included).

1 Like

Read my earlier comment

I’m having this same issue. What was the fix and does citra work on the rog ally?

Any advice would be appreciated tried a system restore that didn’t work

Thank you but I did that already. Still crashing on launch.

1 Like

Same issue here. Log file is empty. (along with log file old.txt) I have deleted all folders, tried the nightly builds from Jan 28th, 29th and 31st. It’s a complete crash 3-5 seconds after app startup. Doesn’t even show the rom list before crashing.

Rolled back Windows update from 1/31. No change.

Okay so…I don’t know how it worked, but

Compatibility mode was running everything at a much slower rate for me. Framerate stutters/speedups. It works, but it feels a little too unstable at times. It worried me enough that I did some digging and found a Windows Security update (KB5034123) that was hiding out behind a few other updates.

A week ago I uninstalled Security Update (KB5034123) and Citra worked fine. But a different update reinstalled it behind a different code: Update for Microsoft Windows (KB5034204)

I uninstalled “Update for Microsoft Windows (KB5034204)” and restarted. No change at all - Citra still crashed on startup. But when I went to Uninstall updates under Windows Update I discovered “Windows Security update (KB5034123)” was present again in my installed updates somehow. I uninstalled it once more and restarted.

Citra Nightly 2091 is now running flawlessly. No compatibility modes. No need to run as Administrator. It just works. And it might be my imagination, but it even looks like the frame rate is running smoother.

I don’t know if this issue exists for anyone else outside of ROG Ally users, but it is night and day difference after getting rid of “Windows Security update (KB5034123).” Maybe that’s where the compatibility issue lies.

Managed to make it work, I set the compatibility on properties to Windows 8 and after that I executed citra-qt as Administrator.

I got it to work by going into the Appdata folder and removing the citra folder. After that downloaded Citra back and have had no issues