Citra freezes my whole computer while launching the game. RAM goes to 99% usage

Issue:
Citra freezes my computer when loading up Tomodatchi Life. RAM goes to 99% usage. This only started happening recently fsr.

System Information

  • Operating System: Windows 10 Pro
  • CPU: FX-6300 4.2GHZ
  • GPU: GTX 1060
  • RAM: 16GB DDR3
  • Citra Version (found in title bar): CITRA NIGHTLY 1415
  • Game: Tomodatchi Life
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (4.0 KB)

System Information for Support

Client Version                                Nightly 1415 HEAD-eb0364d
OpenGL Vendor                                 null
OpenGL Renderer                               null
OpenGL Version                                null
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Hm, test to turn off Disk Shader Cache in the graphics options and see if that stops it.

1 Like

thanks helped x vjndcfhdvd

Did it get completely fixed when you turned it off?

Just wanted to say I was having this same exact issue as OP. I thought it was an issue with the newer build but after turning off Disk Shader Cache the issue vanished. With DSC on Citra would completely lock my computer up, with no response, for up to 3-5 minutes. Memory and disk usage would go through the roof but more so the memory.

I was having the same problem, i confirmd uh the disk shader cache was the responsible.
Thanks at all for the topic! =D

oh my god why iam so stupid:( thank you now I can play my SOS again :slight_smile:

For those who want to continue using the Disk Shader Cache to reduce stuttering in-game, without having your ram use skyrocket, please follow these steps:

  1. Open Citra then go to File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder if it is there.
  3. Emulation->Configure… then click on Graphics on the left
  4. Click on the Advanced tab and turn on Accurate Multiplication

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to load all shaders slowly from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.